View Revisions: Issue #1813

Summary 0001813: Use of deprecated texture2D() in OpenGL 3.1+ shaders
Revision 2020-10-17 10:38 by Ext3h
Description In NoesisGUI 3.0.4 you still got this right, and used `texture()` rather than deprecated `texture2D()` in your GLSL #140 code.

In 3.0.5 / 3.0.6, for an unknown reason, you started using `texture2D()` which is only available in explicit compatbility profiles, but not in standard, forward compatible profiles.
Revision 2020-10-17 10:28 by Ext3h
Description In NoesisGUI 3.0.4 you still got this right, and used `texture()` rather than deprecated `texture2D()` in your GLSL #140 code.

In 3.0.6, for an unknown reason, you started using `texture2D()` which is only available in explicit compatbility profiles, but not in standard, forward compatible profiles.