View Issue Details

IDProjectCategoryView StatusLast Update
0001456NoesisGUIC# SDKpublic2019-04-26 12:40
ReporterdstroupAssigned Tosfernandez 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0001456: BitmapImage strips leading "/" in paths on Linux
DescriptionSimilar to issue 0001455, passing an absolute path to Noesis.BitmapImage results in FileTextureProvider::OpenStream called without the leading "/" when on Linux.

This used to work in 2.2.0, but is broken in 2.2.1.
Steps To ReproduceCalling this:
Noesis.BitmapImage bitmapImage = new Noesis.BitmapImage(new Uri("/home/user/image.bmp"));

Results in a FileNotFoundException because the path provided to the FileTextureProvider is missing the leading "/"
    public class FileSystemTextureProvider : FileTextureProvider
    {
        public FileSystemTextureProvider()
        {
        }

        public override Stream OpenStream(string path)
        {
            return new FileStream("home/user/image.bmp", FileMode.Open, FileAccess.Read); // Crash due to missing "/"
        }
    }
TagsNo tags attached.
PlatformLinux

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-04-25 22:18 dstroup New Issue
2019-04-25 23:14 jsantos Assigned To => sfernandez
2019-04-25 23:14 jsantos Status new => assigned
2019-04-25 23:14 jsantos Target Version => 2.2.2
2019-04-26 12:40 sfernandez Status assigned => resolved
2019-04-26 12:40 sfernandez Resolution open => fixed
2019-04-26 12:40 sfernandez Fixed in Version => 2.2.2