View Issue Details

IDProjectCategoryView StatusLast Update
0001458NoesisGUIUnity3Dpublic2019-07-24 12:24
ReporterstonstadAssigned Tojsantos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version 
Target Version2.2.4Fixed in Version 
Summary0001458: Error On Subsequent Package Import
DescriptionI always get the error message shown (encl. erroronpackageimport.png) when I import a newer version of Noesis. I am currently having to delete the DLL, which causes problems for assets, which sometimes need to be rebuilt as a result.
TagsNo tags attached.
PlatformAny

Relationships

related to 0001490 resolvedsfernandez Upgrade from 2.2.2 to 2.2.3 Crash and Corruption 

Activities

stonstad

stonstad

2019-04-29 16:41

reporter  

ErrorOnPackageImport.PNG (19,505 bytes)
ErrorOnPackageImport.PNG (19,505 bytes)
stonstad

stonstad

2019-06-13 18:02

reporter   ~0005699

Confirmed this happens with 2.2.3.

Error.PNG (11,063 bytes)
Error.PNG (11,063 bytes)
jsantos

jsantos

2019-06-14 14:02

manager   ~0005700

We have contacted Unity many times about this. It is an awful limitation of native plugins in Unity. If you import a new package that tries to overwrite a native library (Noesis.dll) that is being used by Unity you will get that error, the package will be imported but you will have a mix of the new package and old one and the chances of crashing are high.

Aren't you getting a message (from our plugin) about restarting Unity? We try to detect that scenario and recommend restarting Unity.

It is also commented in the Unity tutorial. Although I think we should put more emphasis in that:

"Although not strictly necessary we recommend closing Unity and removing the folders '/Assets/NoesisGUI/Plugins and '/Assets/NoesisGUI/Samples' before installing a new version of NoesisGUI"
stonstad

stonstad

2019-06-14 14:41

reporter   ~0005702

I didn't get to the restart message -- I think because I chose force quit and then deleted the files. I completely accept this as a limitation of Unity and I'm able to work around it.
sfernandez

sfernandez

2019-07-24 12:24

manager   ~0005899

Unity limitation, can't fix.

Issue History

Date Modified Username Field Change
2019-04-29 16:41 stonstad New Issue
2019-04-29 16:41 stonstad File Added: ErrorOnPackageImport.PNG
2019-04-30 18:19 jsantos Assigned To => jsantos
2019-04-30 18:19 jsantos Status new => assigned
2019-06-13 18:02 stonstad File Added: Error.PNG
2019-06-13 18:02 stonstad Note Added: 0005699
2019-06-14 14:02 jsantos Note Added: 0005700
2019-06-14 14:04 jsantos Status assigned => feedback
2019-06-14 14:05 jsantos Relationship added related to 0001490
2019-06-14 14:41 stonstad Note Added: 0005702
2019-06-14 14:41 stonstad Status feedback => assigned
2019-06-18 17:02 sfernandez Target Version => 2.2.4
2019-07-24 12:24 sfernandez Status assigned => resolved
2019-07-24 12:24 sfernandez Resolution open => not fixable
2019-07-24 12:24 sfernandez Note Added: 0005899