View Issue Details

IDProjectCategoryView StatusLast Update
0002206NoesisGUIC++ SDKpublic2022-03-02 13:15
Reporterpdx_lysannschlegel Assigned Tojsantos  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.1.1 
Target Version3.1.3Fixed in Version3.1.3 
Summary0002206: Expose StringFormat and the global CultureInfo object
DescriptionFrom this forum thread: https://www.noesisengine.com/forums/viewtopic.php?f=3&t=2468

When making a markup extension/converter I realized that I cannot easily provide a property to the user that behaves like StringFormat in a binding, as in, actually implementing the formatting itself.
Since there is an implementation for it in the C++ SDK to support it for Bindings, it would be nice to have it available in the SDK, so my usage of it behaves the same as in the rest of Noesis, and in XAML we can just use the familiar syntax without having to reinvent the wheel on the C++ side.

Not sure how the CultureInfo would be best passed in. Converteres seem to be lacking it right now. Even outside of converters it would be nice to get access to the global CultureInfo we can set via Noesis::GUI::SetCulture, but this could worked around if necessary.
TagsNo tags attached.
PlatformAny

Activities

jsantos

jsantos

2022-03-02 13:15

manager   ~0007828

Solved in r11236 and r11237

- StringFormat.h is now a public header
- Added Noesis::GUI::GetCulture()

Issue History

Date Modified Username Field Change
2021-12-03 10:10 pdx_lysannschlegel New Issue
2021-12-06 14:49 jsantos Assigned To => jsantos
2021-12-06 14:49 jsantos Status new => assigned
2021-12-06 14:51 jsantos Target Version => 3.1.3
2022-03-02 13:15 jsantos Status assigned => resolved
2022-03-02 13:15 jsantos Resolution open => fixed
2022-03-02 13:15 jsantos Fixed in Version => 3.1.3
2022-03-02 13:15 jsantos Note Added: 0007828