View Issue Details

IDProjectCategoryView StatusLast Update
0002438NoesisGUIUnity3Dpublic2022-11-12 02:54
ReporterCaptainCatSparrow Assigned Tojsantos  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.5 
Target Version3.1.6Fixed in Version3.1.6 
Summary0002438: Unity URP camera stacking not working properly with Noesis GUI (GUI is invisible) on Android device
DescriptionNoesisGUI version 3.1.5
Unity version 2021.2.16f1
URP version 12.1.6
Steps To ReproduceA simple project to reproduce an issue is attached.
Camera stacking example with 2 camera: 1st is for 3d world, 2nd is for NoesisGUI. Everything works fine in Editor (Game/Simulator view) on Play.
On Android device NoesisGui is not visible, but button clicks/taps are working (in the attached example the text "Controls Gallery" in the center of the screen is tapable and changes non-noesis camera background color on tap).
TagsAndroid, Unity, Unity URP
PlatformAndroid

Activities

CaptainCatSparrow

CaptainCatSparrow

2022-10-06 23:03

reporter  

Gallery.zip (4,621,516 bytes)
jsantos

jsantos

2022-10-07 12:46

manager   ~0008092

Thanks for the report.

One question, to see if this is Noesis or Unity related. If in the UI camera (2nd one), you render geometry instead of UI, does the geometry disappear too?
CaptainCatSparrow

CaptainCatSparrow

2022-10-07 14:01

reporter   ~0008093

Just tested it: a 3D cube added to scene (in a view of UI camera) is visible both in editor and device.
CaptainCatSparrow

CaptainCatSparrow

2022-10-07 14:11

reporter   ~0008094

Initially tested on Huawei Honor 9. Just tested on another device (Xiaomi Redmi Note 7), the issue is still reproducible
jsantos

jsantos

2022-10-07 18:04

manager   ~0008095

I will investigate this as soon as possible.

If you could send a renderdoc capture (from android) before that, I can start figuring out things.

Thanks!
CaptainCatSparrow

CaptainCatSparrow

2022-10-09 23:47

reporter   ~0008096

Never actually worked with renderdoc, so if anything is wrong let me know
Capture.rdc (1,549,154 bytes)
jsantos

jsantos

2022-10-10 11:04

manager   ~0008097

Thank you!
jsantos

jsantos

2022-11-12 02:54

manager   ~0008151

We have been testing different versions of URP recently and based on our measurements, we strongly encourage to avoid camera stacking on Android. There is a lot of overhead loading and storing intermediate render targets. It gives me the impression Camera Stacking is not well tested on Android (I would even say, URP in general). As you discovered is also buggy in comparison with how Desktop is implemented. Latest versions we tested (2022.1) are a bit better but still quite inefficient and buggy.

In NoesisGUI 3.1.6 we have exposed a new property in the View to control when the UI renderpass executes ("Injection Point"). This way, camera stacking can be avoided.

Please, feel free to reopen to comment.

Issue History

Date Modified Username Field Change
2022-10-06 23:03 CaptainCatSparrow New Issue
2022-10-06 23:03 CaptainCatSparrow Tag Attached: Android
2022-10-06 23:03 CaptainCatSparrow Tag Attached: Unity
2022-10-06 23:03 CaptainCatSparrow Tag Attached: Unity URP
2022-10-06 23:03 CaptainCatSparrow File Added: Gallery.zip
2022-10-07 12:45 jsantos Assigned To => jsantos
2022-10-07 12:45 jsantos Status new => assigned
2022-10-07 12:46 jsantos Note Added: 0008092
2022-10-07 12:46 jsantos Status assigned => feedback
2022-10-07 14:01 CaptainCatSparrow Note Added: 0008093
2022-10-07 14:01 CaptainCatSparrow Status feedback => assigned
2022-10-07 14:02 CaptainCatSparrow Description Updated
2022-10-07 14:11 CaptainCatSparrow Note Added: 0008094
2022-10-07 14:16 jsantos Target Version => 3.1.6
2022-10-07 18:04 jsantos Note Added: 0008095
2022-10-07 18:04 jsantos Status assigned => feedback
2022-10-09 23:47 CaptainCatSparrow Note Added: 0008096
2022-10-09 23:47 CaptainCatSparrow File Added: Capture.rdc
2022-10-09 23:47 CaptainCatSparrow Status feedback => assigned
2022-10-10 11:04 jsantos Note Added: 0008097
2022-11-07 17:13 sfernandez Target Version 3.1.6 => 3.1.7
2022-11-07 17:15 sfernandez Target Version 3.1.7 => 3.1.6
2022-11-12 02:54 jsantos Status assigned => resolved
2022-11-12 02:54 jsantos Resolution open => fixed
2022-11-12 02:54 jsantos Fixed in Version => 3.1.6
2022-11-12 02:54 jsantos Note Added: 0008151