View Issue Details

IDProjectCategoryView StatusLast Update
0002685NoesisGUIUnity3Dpublic2024-06-10 10:59
ReporterJosh Campbell Assigned Tosfernandez  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version3.2 
Target Version3.2.4Fixed in Version3.2.4 
Summary0002685: When special characters for keybindings unity crashes
DescriptionAlphabetical characters and numeric characters work but special characters like ! cause a unity crash.
TagsNo tags attached.
PlatformAny

Activities

sfernandez

sfernandez

2023-09-11 11:35

manager   ~0008714

Can you attach the XAML you use for the key binding?
Do you get any error message when the XAML is imported?
sfernandez

sfernandez

2023-09-27 11:30

manager   ~0008776

Any chance to get a crash dump for this? I wasn't able to reproduce the issue.
Josh Campbell

Josh Campbell

2023-09-27 19:01

reporter   ~0008783

Last edited: 2023-09-27 19:02

This is the info the dev provided me with. Please let me know what else we can get for you, I can try to get a crash log later this week.


"So in the keyboard it was that"

<Grid Width="740" >
        <Grid.InputBindings>
            <KeyBinding Command="{Binding ExclamationPointCommandBinding}" Key="Oem1" />
        </Grid.InputBindings>
.... (edited)

It broke for other keys too... pretty much every Oem and some button between caps, shift and ctrl but can't remember which one

and was not able to use any modifier but binding with all letters was ok

<KeyBinding Command="{Binding ExclamationPointCommandBinding}" Key="1" Modifiers="Shift" />
sfernandez

sfernandez

2024-06-03 20:22

manager   ~0009625

We recently added support for some missing Oem characters when mapping Unity keys to Noesis Key enum (changeset 13492 and 14026).
But we never were able to reproduce a crash using those keys, is this is still an issue?
sfernandez

sfernandez

2024-06-10 10:59

manager   ~0009677

Please reopen if you find this issue again.

Issue History

Date Modified Username Field Change
2023-09-08 23:22 Josh Campbell New Issue
2023-09-11 11:35 sfernandez Assigned To => sfernandez
2023-09-11 11:35 sfernandez Status new => feedback
2023-09-11 11:35 sfernandez Note Added: 0008714
2023-09-11 11:35 sfernandez Target Version => 3.2.2
2023-09-27 11:30 sfernandez Note Added: 0008776
2023-09-27 11:30 sfernandez Target Version 3.2.2 => 3.2.3
2023-09-27 19:01 Josh Campbell Note Added: 0008783
2023-09-27 19:01 Josh Campbell Status feedback => assigned
2023-09-27 19:02 Josh Campbell Note Edited: 0008783
2024-01-22 11:46 sfernandez Target Version 3.2.3 => 3.2.4
2024-06-03 20:22 sfernandez Status assigned => feedback
2024-06-03 20:22 sfernandez Note Added: 0009625
2024-06-10 10:59 sfernandez Status feedback => resolved
2024-06-10 10:59 sfernandez Resolution open => unable to reproduce
2024-06-10 10:59 sfernandez Fixed in Version => 3.2.4
2024-06-10 10:59 sfernandez Note Added: 0009677