View Issue Details

IDProjectCategoryView StatusLast Update
0002860NoesisGUIStudiopublic2024-01-02 13:14
Reportersfernandez Assigned Todfranjic  
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Target VersionStudio_AlphaFixed in VersionStudio_Alpha 
Summary0002860: Crash using a BitmapImage in design DataContext
Description1. Create a dynamic class in Data panel.
2. Add an object property with type BitmapImage
3. Assign data context to root object
4. Edit image property and assign a BitmapImage object
5. Choosing from the UriSource combo box an image will crash the Studio
TagsNo tags attached.
PlatformAny

Activities

sfernandez

sfernandez

2023-12-21 16:11

manager   ~0009043

I think it is with BitmapSource instead
dfranjic

dfranjic

2023-12-21 17:58

developer   ~0009044

Have you been able to reproduce this bug lately? I can't reproduce it following the given steps (with BitmapSource or BitmapImage). If it's not fixed, I feel like something has to be done before these steps.

With r13123 I fixed an issue where XamlUndoRedoCommand would try to access design data context objects NodeObject as if they're part of the XAML document you're viewing, but since they're handled differently it caused a crash.
Fix for the 0002956 I committed a week ago could've also fixed this bug, it could've been the same cause.

Issue History

Date Modified Username Field Change
2023-11-21 17:56 sfernandez New Issue
2023-11-21 17:56 sfernandez Target Version => Studio_Alpha
2023-11-21 17:57 sfernandez Assigned To => dfranjic
2023-11-21 17:57 sfernandez Status new => assigned
2023-12-21 16:11 sfernandez Note Added: 0009043
2023-12-21 17:58 dfranjic Note Added: 0009044
2024-01-02 13:14 sfernandez Status assigned => resolved
2024-01-02 13:14 sfernandez Resolution open => fixed
2024-01-02 13:14 sfernandez Fixed in Version => Studio_Alpha