View Issue Details

IDProjectCategoryView StatusLast Update
0003290NoesisGUIStudiopublic2024-05-13 14:28
Reportermaherne Assigned Tomaherne  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product VersionStudio_Alpha 
Target VersionStudio_AlphaFixed in VersionStudio_Alpha 
Summary0003290: Crash when trying to edit an type selected DataTemplate in another dictionary
DescriptionWhen trying to edit a DataTemplate inline, and that DataTemplate is in another document and has been selected based on type, Studio crashes.

It seems to be trying to find the template's node in the current document, rather than in the document where it exists.
Steps To ReproduceDownload and open the attached project
Open AutoSelectedContentTemplate.xaml
Right click on the ContentControl and select Templates > Content > Edit
TagsNo tags attached.
PlatformAny

Activities

maherne

maherne

2024-05-13 12:16

developer   ~0009523

Attaching project which replicates the issue.
DataTemplateCrash.zip (2,458 bytes)

Issue History

Date Modified Username Field Change
2024-05-02 14:13 maherne New Issue
2024-05-02 14:13 maherne Target Version => Studio_Alpha
2024-05-03 14:33 jsantos Assigned To => dfranjic
2024-05-03 14:33 jsantos Status new => assigned
2024-05-13 12:16 maherne Note Added: 0009523
2024-05-13 12:16 maherne File Added: DataTemplateCrash.zip
2024-05-13 14:27 maherne Assigned To dfranjic => maherne
2024-05-13 14:28 maherne Status assigned => resolved
2024-05-13 14:28 maherne Resolution open => fixed
2024-05-13 14:28 maherne Fixed in Version => Studio_Alpha