View Issue Details

IDProjectCategoryView StatusLast Update
0003365NoesisGUIStudiopublic2024-06-13 20:22
Reporterdstewart Assigned Todfranjic  
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product VersionStudio_A1 
Target VersionStudio_A1 
Summary0003365: Crash Deleting Style from Dictionary
DescriptionThis crash occured when deleting a TextBlock Style from a ResourceDictionary.
I'm not sure if this had an impact, but it's worth noting that the Style that was deleted was part of of a ResourceDicitonary that was being fed into a MergedDictionary.

Dump attached.
Steps To ReproduceI can't reproduce this. But this occured in the following scenario:

4 ResourceDictionaries inside of a folder at the project root:
Style_A
Style_B
Style_C
Style_Master (Style_A merged into this Dictionary)

Each Style_A, Style_B, and Style_C has two TextBlock Styles assigned to each.
Each has a TextBlock Styled named "Style_Header" and "Style_Body".

The crash then occured when deleting "Style_Body" from the Style_A dictionary.
TagsNo tags attached.
PlatformAny

Relationships

related to 0003366 resolveddfranjic If Multiple Styles Use the Same x:keys, Deleting a Style Deletes the x:keys for the Other Styles 

Activities

dstewart

dstewart

2024-06-07 12:28

reporter  

20240607_061650.dmp (102,892 bytes)
dstewart

dstewart

2024-06-10 17:03

reporter   ~0009681

Unable to repro this, but following the steps in this ticket, I got the errors logged in: https://www.noesisengine.com/bugs/view.php?id=3366
(So, I think it's safe to close this one with the new for 3366 resolving what likely caused the crash to begin with here)
dfranjic

dfranjic

2024-06-10 20:32

developer   ~0009686

I researched this and I think the ticket should stay open. The dump says that the crash occurred in code related to dummy editor. There's a bug now that when you delete a resource (such as a style) that's being edited in the dummy editor, the Studio doesn't leave the dummy scope and you can still edit the style even though it's deleted. So I think that was the cause of your crash.
dstewart

dstewart

2024-06-11 11:14

reporter   ~0009689

Sounds good, Dario - open it shall stay!

Issue History

Date Modified Username Field Change
2024-06-07 12:28 dstewart New Issue
2024-06-07 12:28 dstewart File Added: 20240607_061650.dmp
2024-06-07 13:24 dfranjic Assigned To => dfranjic
2024-06-07 13:24 dfranjic Status new => assigned
2024-06-10 12:33 jsantos Target Version => Studio_A1
2024-06-10 17:01 dstewart Relationship added related to 0003366
2024-06-10 17:03 dstewart Note Added: 0009681
2024-06-10 20:32 dfranjic Note Added: 0009686
2024-06-11 11:14 dstewart Note Added: 0009689
2024-06-13 20:22 dfranjic Status assigned => resolved
2024-06-13 20:22 dfranjic Resolution open => fixed