Page 1 of 1

Unable to use Assembly Definition file with Noesis 2.2 in Unity 2019.1.7

Posted: 24 Jun 2019, 06:35
by horeaper
Back in 2.1, I was able to speed up script development by adding two Assembly Definition files under NoesisGUI/Plugins and NoesisGUI/Plugins/Editor folder, set the platform and reference, and it will works just fine.
But now, when trying to do the same thing with 2.2.3, Unity gives me an error saying:
Instance of NoesisViewEditor couldn't be created. The script class needs to derive from ScriptableObject and be placed in the Assets/Editor folder.
And the Noesis View (Script) component gives me some weird display, as shown in attachment.
Can't get my head around it...

Re: Unable to use Assembly Definition file with Noesis 2.2 in Unity 2019.1.7

Posted: 26 Jun 2019, 14:30
by jsantos
I am not sure if this is a bug in Unity, because NoesisViewEditor inherits from Editor, a ScriptableObject. So, with the same version of Unity, Noesis 2.2.3 doesn't work and Noesis 2.1.X works?

.

Re: Unable to use Assembly Definition file with Noesis 2.2 in Unity 2019.1.7

Posted: 29 Jun 2019, 08:17
by horeaper
I am not sure if this is a bug in Unity, because NoesisViewEditor inherits from Editor, a ScriptableObject. So, with the same version of Unity, Noesis 2.2.3 doesn't work and Noesis 2.1.X works?
Fixed by restart UnityHub.... wtf??🤣

Re: Unable to use Assembly Definition file with Noesis 2.2 in Unity 2019.1.7

Posted: 01 Jul 2019, 15:21
by jsantos
It is called, Unity magic. 🤣