Page 1 of 1

Moving NoesisGUI inside a subfolder causes it to reinstall every time on run.

Posted: 19 May 2020, 19:47
by SrdjanMaksimovic021
Hi there!

So I am experiencing an issue when I move the NoesisGUI folder inside another subfolder in the Unity project and then press play. The plugin reinstalls as soon as the scene loads and if I stop it and play it again, same thing happens every time. It otherwise works, but this operation takes around 20 minutes every time play is pressed, so it makes the project almost unworkable. It works correcly inside the root Assets folder, but I am working on a large project with multiple developers and many other plugins, so it remaining in the Assets folder doesn't work for us.

Is there a way to move the NoesisGUI folder inside another subfolder without it reinstalling every time the project is run in the editor?
Or is there some workaround?

Thank you in advance!

Additional info (might be helpful): After it reinstalls during play, the popup which notifies the install completed and redirects to documentation and such appears as usual, however, unlike when it is properly installed for the first time, it contains no pictures, only text.

Re: Moving NoesisGUI inside a subfolder causes it to reinstall every time on run.

Posted: 19 May 2020, 20:21
by stonstad
+1 for this change. I prefer to keep Unity plugins in a \plugins folder. The last time I tried this w/ Noesis it didn't like it.

Re: Moving NoesisGUI inside a subfolder causes it to reinstall every time on run.

Posted: 20 May 2020, 11:11
by jsantos
This was reported long time ago as #1330. I have moved it to 3.0 roadmap.