cuddlypike
Topic Author
Posts: 2
Joined: 15 Aug 2015, 20:50

At least VertexShader 3 is required

07 Oct 2015, 04:46

Hello,

I'm testing my Unity App made with Noesis (v1.2.4) and Unity 5.2 on a lower end computer.
I'm getting the error: "At least VertexShader 3 is required"

I found an old post mentioning this issue with the possibility of future support for VertexShader 2.
viewtopic.php?f=3&t=51&p=244&hilit=+At+ ... ired+#p244

Has anything progressed in regards to this support?

It also suggests changing the render settings to use OpenGL, but doing that makes Unity very unstable and glitchy, eventually crashing when attempting to build.

Any help would be greatly appreciated.

Thanks!
 
User avatar
jsantos
Site Admin
Posts: 2922
Joined: 20 Jan 2012, 17:18
Contact:

Re: At least VertexShader 3 is required

07 Oct 2015, 19:46

This is one of the things I have been investigating for v1.2.5. Unfortunately the improvements we are doing for noesisGUI v1.3.x (like BlurEffects and DropShadowEffects) are not very compatible with Shader Model 2.0. Add to that the fact that Unity is also deprecating Shader Model 2.0 GPUs. We are seriously considering statying with 3.0 and up. How critical is this for you?

Could you elaborate about the problems you are having with OpenGL? Are they related to NoesisGUI?
 
cuddlypike
Topic Author
Posts: 2
Joined: 15 Aug 2015, 20:50

Re: At least VertexShader 3 is required

15 Oct 2015, 20:08

Hmm... I hadn't seen that announcement from Unity.
In light of that, I may have to reconsider my own minimum specs. :P

It would still be nice to have a version of Noesis that supported VertexShader 3 (even if it were just the basic functionality, without the nicer effects), if I were to restrict myself to an older version of Unity 5. However, I would understand that you don't get as much value out of the work involved, if Unity won't even support it in six months.

As far as how critical all this is, I don't really know for sure. It's probably something I can do without, though I will have to do some further research to see. It is just nicer to be able to support the widest number of computers. VertexShader 2 is pretty old, so there shouldn't be many systems out there any longer, I would suppose.

I believe all issues I was having with OpenGL were related to Unity itself, rather than Noesis.

Thanks!
 
User avatar
jsantos
Site Admin
Posts: 2922
Joined: 20 Jan 2012, 17:18
Contact:

Re: At least VertexShader 3 is required

16 Oct 2015, 17:06

At least in our database, all the D3D9 cards not supporting Shader Model 3.0 have Software (not in HW) Vertex implementation. So yes, it is probably a good idea reconsidering the minimum specs about this.

Who is online

Users browsing this forum: No registered users and 4 guests