Sumel007
Topic Author
Posts: 30
Joined: 19 Mar 2020, 10:50

Embedded fonts not found in Noesis 3.2

23 Mar 2023, 13:33

Hey. I wanted to ask if we're supposed to change the way fonts are referenced in xaml with the changes in 3.2?
I reference fonts like this:
<FontFamily x:Key="WorkSansFont">Work Sans, pack://application:,,,/Fonts/#Work Sans, pack://application:,,,/Fonts/#Noto Sans Arabic, pack://application:,,,/Fonts/#Noto Sans SC, pack://application:,,,/Fonts/#Noto Sans JP, pack://application:,,,/Fonts/#Noto Sans KR</FontFamily>
The fonts are embedded resources and we use Embedded font provider from Noesis.App. It was all working fine on 3.1.7, but broke on 3.2 and gives errors that the font is not found (for all the referenced fonts). Reverting to 3.1.7 fixed the issue. It seems that in 3.2 EmbeddedFontProvider.FamilyExists returns false for all of the fonts.
 
User avatar
sfernandez
Site Admin
Posts: 3029
Joined: 22 Dec 2011, 19:20

Re: Embedded fonts not found in Noesis 3.2

27 Mar 2023, 19:14

Could you please report this in our bugtracker?
In the meantime you can change the font family definition to:
<FontFamily x:Key="WorkSansFont">Work Sans, Fonts/#Work Sans, Fonts/#Noto Sans Arabic, Fonts/#Noto Sans SC, Fonts/#Noto Sans JP, Fonts/#Noto Sans KR</FontFamily>
 
Sumel007
Topic Author
Posts: 30
Joined: 19 Mar 2020, 10:50

Re: Embedded fonts not found in Noesis 3.2

28 Mar 2023, 11:42

They way you specified also doesn't work - it still doesn't find the font.
I also tried /Fonts/#Work Sans and it doesn't work either.
../Fonts/#Work Sans works (the folder structure is like Fonts/FontX.otf and Styles/BaseResourceDictionary.xaml, hence the .. to get correct relative path). There are no errors with the font not being found.

But it seems like one of our fonts is still not rendered - Roboto Condensed. I assume it might be a problem due to the font name containing the word "condensed" and maybe the praser thinks it should be font Roboto, with font stretch Condensed?

I've created two tickets - here's the one for the embedded fonts / global URIs problem (the original one) https://www.noesisengine.com/bugs/view.php?id=2545
Here's the second one for Roboto Condensed (I assume they are two separate issues, hence separate tickets): https://www.noesisengine.com/bugs/view.php?id=2546
 
User avatar
sfernandez
Site Admin
Posts: 3029
Joined: 22 Dec 2011, 19:20

Re: Embedded fonts not found in Noesis 3.2

29 Mar 2023, 13:38

Thanks, we solved issue #2545 for next 3.2.1 version, and as mentioned in ticket #2546 the behavior is expected for the new font differentiation algorithm that matches WPF. Marking this post as solved.

Who is online

Users browsing this forum: Bing [Bot] and 29 guests