haowang1013
Topic Author
Posts: 10
Joined: 15 Sep 2014, 03:16

support for unity 5

23 Sep 2014, 12:04

Hi,

Given the fact that unity 5 beta is already released, I'm wondering what the plan is to make Noesis support unity 5.
 
movra
Posts: 70
Joined: 02 Apr 2014, 20:35

Re: support for unity 5

23 Sep 2014, 13:31

Did you encounter problems with Noesis in Unity 5?
 
haowang1013
Topic Author
Posts: 10
Joined: 15 Sep 2014, 03:16

Re: support for unity 5

24 Sep 2014, 03:11

Did you encounter problems with Noesis in Unity 5?
Yes, there were some errors when importing the noesis packages in unity 5.

If that's not expected, shall I file a bug instead?
 
movra
Posts: 70
Joined: 02 Apr 2014, 20:35

Re: support for unity 5

24 Sep 2014, 15:12

Could you please tell us what kind of errors?

I have no access to the closed beta of Unity 5 so I cannot see it for myself. But maybe we can investigate the error messages.

It may also be a good idea to wait for a public release of Unity 5 in case the errors are a defect of the Unity 5 beta itself. Because then it would just be a waste of time trying to solve it on Noesis' side.
 
User avatar
jsantos
Site Admin
Posts: 2900
Joined: 20 Jan 2012, 17:18
Contact:

Re: support for unity 5

24 Sep 2014, 17:16

Yes, please, paste the errors here. For now we didnt't have time to test that version with NoesisGUI.
 
haowang1013
Topic Author
Posts: 10
Joined: 15 Sep 2014, 03:16

Re: support for unity 5

25 Sep 2014, 04:11

Ah, don't bother in that case then.

I thought the beta is for everyone. I'll confirm again once the 5.0 build is made available for the public.

Thanks
 
golgepapaz
Posts: 43
Joined: 01 Aug 2013, 01:59

Re: support for unity 5

29 Sep 2014, 15:56

I think Unity 5 needs x64 version of the editor dll. Here is the error;

Noesis is already added, previous path 'Assets/Plugins/x86_64/Noesis.dll', trying to add 'Assets/Editor/NoesisGUI/BuildTool/Noesis.dll'
 
User avatar
jsantos
Site Admin
Posts: 2900
Joined: 20 Jan 2012, 17:18
Contact:

Re: support for unity 5

29 Sep 2014, 16:01

So the editor is always 64 bits in Unity5?
 
michaljabrzyk
Posts: 2
Joined: 12 Nov 2016, 01:17

Re: support for unity 5

12 Nov 2016, 01:19

Assets/Plugins/NoesisGUI/Scripts/Core/NoesisUIRenderer.cs(389,82): error CS0619: `UnityEngine.GameObject.camera' is obsolete: `Property camera has been deprecated. Use GetComponent<Camera>() instead. (UnityUpgradable)'
 
User avatar
sfernandez
Site Admin
Posts: 1911
Joined: 22 Dec 2011, 19:20

Re: support for unity 5

01 Dec 2016, 19:56

Assets/Plugins/NoesisGUI/Scripts/Core/NoesisUIRenderer.cs(389,82): error CS0619: `UnityEngine.GameObject.camera' is obsolete: `Property camera has been deprecated. Use GetComponent<Camera>() instead. (UnityUpgradable)'
Hi, sorry for the late reply.

Which version of NoesisGUI are you trying?
Our latest version 1.2.6f5 doesn't use .camera property anymore.
You can ask for a Trial if you are not using the latest version.

Who is online

Users browsing this forum: No registered users and 2 guests