Search found 61 matches

  • 1
  • 2
  • 3
  • 4
  • 5
  • 7
by darthmaule2
12 Jul 2019, 21:39
Forum: General Discussion
Replies: 4
Views: 51

Re: Having trouble using new EventTrigger with InvokeCommandAction (Managed Noesis 2.2.3)

I do have another question about this scenario -- why is the param = null? I would except it would contain the source object so I can know what triggered the command? This happens in your minimal example.
by darthmaule2
12 Jul 2019, 21:30
Forum: General Discussion
Replies: 4
Views: 51

Re: Having trouble using new EventTrigger with InvokeCommandAction (Managed Noesis 2.2.3)

Short story: Thanks for the minimal working example - it helped me figure this out - and I now I see what I did wrong... Long story: When I had previously ported some Prism classes, I saw ICommand was required, but that it was in System.Windows.Input. Thinking (incorrectly, apparently) it was a Wind...
by darthmaule2
11 Jul 2019, 19:26
Forum: General Discussion
Replies: 4
Views: 51

Having trouble using new EventTrigger with InvokeCommandAction (Managed Noesis 2.2.3)

I'm trying to connect the PreviewMouseDown event from my View to a DelegateCommand in my ViewModel. My View's DataContext is properly set to my ViewModel and binding is working fine. View.xaml <UserControl x:Class="Modules.FileManager.FileManagerView" xmlns="http://schemas.microsoft.com/winfx/2006/x...
by darthmaule2
30 May 2019, 12:01
Forum: General Discussion
Replies: 2
Views: 89

Re: Unable to set custom ControlTemplate for a MenuItem

Thanks, I have this working with the style you posted and my template:
        <ControlTemplate x:Key="TopLevelItemTemplate" TargetType="MenuItem">
by darthmaule2
29 May 2019, 22:22
Forum: General Discussion
Replies: 2
Views: 89

Unable to set custom ControlTemplate for a MenuItem

I confirmed the following works in WPF but not in Noesis. I did then realize you didn't yet have complete support for "x:Static"... <ControlTemplate x:Key="{x:Static MenuItem.TopLevelItemTemplateKey}" TargetType="MenuItem"> <Border x:Name="MenuItemBorder" Width="190" Height="100" BorderThickness="1"...
by darthmaule2
14 May 2019, 19:56
Forum: General Discussion
Replies: 1
Views: 109

Trying to bind to a BitmapImage created with a Uri pointing to an embedded resource

I have a folder called "Images" which contains an embedded resource "MyImage.png". I can display that image without any issues if I do it like this <Image Source="Images/MyImage.png"></Image> But, I can't load the image using a Uri from code-behind... I can see that FileTextureProvider::OpenStream(s...
by darthmaule2
25 Apr 2019, 14:12
Forum: General Discussion
Replies: 3
Views: 169

Re: ConnectEvent not being called in Noesis 2.2.2 / .NET 4.6.1 / Windows x64?

Ahh, nevermind. I was not explicitly assigning a SelectionChanged event for my ListView, which I thought was a built-in event. I must have taken that out myself at some point. It's working now.
by darthmaule2
25 Apr 2019, 13:55
Forum: General Discussion
Replies: 3
Views: 169

Re: ConnectEvent not being called in Noesis 2.2.2 / .NET 4.6.1 / Windows x64?

ok that's not a good example... I added an event to the XAML and now ConnectEvent is getting called. But, it's still not working in my other application... I'll have to come up with a better minimal example :)
by darthmaule2
24 Apr 2019, 21:33
Forum: General Discussion
Replies: 3
Views: 169

ConnectEvent not being called in Noesis 2.2.2 / .NET 4.6.1 / Windows x64?

I recently noticed my breakpoint in ConnectEvent wasn't getting called, so, I downloaded the latest tutorials from github and made only 1 change to "Buttons", which was to override ConnectEvent and set a break point when it's called: namespace Buttons { /// <summary> /// Interaction logic for MainWi...
by darthmaule2
23 Feb 2019, 11:39
Forum: General Discussion
Replies: 5
Views: 222

Re: How do I save/render an <Image> element as a file using the managed SDK?

RenderTargetBitmp feature request:
https://www.noesisengine.com/bugs/view.php?id=1410

CroppedBitmap and TransformedBitmap feature request:
https://www.noesisengine.com/bugs/view.php?id=1411
  • 1
  • 2
  • 3
  • 4
  • 5
  • 7