CMarinacci
Topic Author
Posts: 15
Joined: 07 Aug 2017, 02:56

Some NoesisGUI source files no longer compile with new versions of Unity

23 Mar 2021, 21:01

Since upgrading to Unity 2020.3.1.f1, NoesisView.cs and NoesisEditor.cs no longer compile. I was able to compile with Unity 2020.3.0.f1. I also tried Unity 2021.1.0f1, but that didn't work either.

Here are the errors:

Error CS0234 The type or namespace name 'EventSystems' does not exist in the namespace 'UnityEngine' (are you missing an assembly reference?) NoesisView.cs line 577
Error CS0234 The type or namespace name 'EventSystems' does not exist in the namespace 'UnityEngine' (are you missing an assembly reference?) NoesisView.cs line 590
Error CS0234 The type or namespace name 'EventSystems' does not exist in the namespace 'UnityEngine' (are you missing an assembly reference?) NoesisView.cs line 590
Error CS0234 The type or namespace name 'EventSystems' does not exist in the namespace 'UnityEngine' (are you missing an assembly reference?) NoesisView.cs line 598
Error CS0234 The type or namespace name 'UI' does not exist in the namespace 'UnityEngine' (are you missing an assembly reference?) NoesisEditor.cs line 102

I deleted the NoesisGUI folder and reinstalled the package (3.0.11), but that didn't help.

Is there a package that I need to include, has Unity deprecated some functionality, or is there something else?

Thanks,

Chris

Tags:
 
User avatar
sfernandez
Site Admin
Posts: 2109
Joined: 22 Dec 2011, 19:20

Re: Some NoesisGUI source files no longer compile with new versions of Unity

23 Mar 2021, 21:48

I just installed both versions: 2021.1.0f1 and 2020.3.1f1 LTS with the default settings, created a new project, installed NoesisGUI package and it compiled and worked fine.
If you try with a new project does it happen also? Even with the default packages?
 
CMarinacci
Topic Author
Posts: 15
Joined: 07 Aug 2017, 02:56

Re: Some NoesisGUI source files no longer compile with new versions of Unity

24 Mar 2021, 01:47

It works fine with a new project (using the Visual Studio template) on Unity 2021.1.0f1.

After some testing, I figured out that the Visual Scripting package is required for NoesisGUI to compile. I had removed it because I thought it wasn't being used.

Thanks,

Chris

Who is online

Users browsing this forum: Google [Bot] and 2 guests