User avatar
polycular
Topic Author
Posts: 19
Joined: 29 Sep 2015, 18:18

[Unity] OpenGLES2 rendering problem

18 Apr 2017, 16:43

Hey,

we upgraded to Unity 5.6 and NoesisGUI2 for our latest project. Everything works fine so far except a rendering issue on OpenGLES2 devices (Android).
While a solid color rectangle is rendered fine, using an linear gradient brush to fill a rectangle leads to unexpected results (pls see https://www.dropbox.com/s/xfji5wminwxqd ... t.jpg?dl=0).
<Rectangle>
	<Rectangle.Fill>
		<LinearGradientBrush>
		<GradientStop Color="Red" Offset="0" />
		<GradientStop Color="Yellow" Offset="1" />
		</LinearGradientBrush>
	</Rectangle.Fill>
</Rectangle>
Are there any required settings to make this work or is OpenGLES 2 not supported anymore?
 
User avatar
sfernandez
Site Admin
Posts: 1912
Joined: 22 Dec 2011, 19:20

Re: [Unity] OpenGLES2 rendering problem

21 Apr 2017, 17:23

Hi,

I was not able to reproduce this issue here.
Could you please create a ticket in our bugtracker and specify which device model and gpu is giving you problems?
It is failing when using the NoesisView in the Main Camera or using it attached to a game object with a RenderTexture?

Thanks for your collaboration.
 
User avatar
polycular
Topic Author
Posts: 19
Joined: 29 Sep 2015, 18:18

Re: [Unity] OpenGLES2 rendering problem

24 Apr 2017, 10:52

Hi,

I created a bugtracker ticket : https://bugs.noesisengine.com/view.php?id=1060
It failed using the NoesisView on the Main Camera.

You're welcome! Pls get back to me if you need more information.
 
tomczak
Posts: 30
Joined: 26 Mar 2014, 10:25

Re: [Unity] OpenGLES2 rendering problem

25 Apr 2017, 11:29

Hi there,

Same here : Rendering issues on a Archos 101d Neon ( http://www.archos.com/fr/products/table ... html#specs ) :

• CPU : MTK 8127 Quad-core ARM Cortex A7 @ 1.3 GHz
• GPU : Quad core GPU Mali 450MP4
• RAM : 1 GB
• Internal Storage : 16GB
• Expandable Storage : Micro SD card up to 64 GB (when formatted to fat32 standard)

Issues :
• Fonts not displayed
• Images not displayed
• Background not displayed

To ensure the issues weren’t introduced by the update process, I’ve created a blank project just with Noesis 2.0.1 package and the Button test scene => Same issues

It was my main targeted device, for its a quite recent low-end device, and Noesis 1.2 and our software were running flawlessly on it.

Btw, no issues on Samsung Galaxy S6

Please see the attached picture :
20170425_112032.jpg
 
User avatar
jsantos
Site Admin
Posts: 2904
Joined: 20 Jan 2012, 17:18
Contact:

Re: [Unity] OpenGLES2 rendering problem

25 Apr 2017, 20:50

Tomczak, could you please file a report for this? We are going to send you a debug version of Noesis to collect more information about it.
 
tomczak
Posts: 30
Joined: 26 Mar 2014, 10:25

Re: [Unity] OpenGLES2 rendering problem

27 Apr 2017, 09:12

Who is online

Users browsing this forum: No registered users and 2 guests