View Issue Details

IDProjectCategoryView StatusLast Update
0001403NoesisGUIUnity3Dpublic2019-04-05 12:24
ReporterKhonanAssigned Tosfernandez 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.1.0f1 
Target VersionFixed in Version 
Summary0001403: Setting a fontfamily constant in a style makes unity Crash (fixed, not a bug)
DescriptionSetting a fontfamily constant in a style makes unity Crash
Using unity 2018.3.3f1
Steps To Reproduce1/ Get NocturnalStyle.xaml
2/ Add this line on top of the style :

    <FontFamily x:Key="DefaultFontFamily">Fonts/#Roboto</FontFamily>

3/ use the style in your code :
            ResourceDictionary style = (ResourceDictionary)LoadXaml("NocturnalStyle");
            Noesis.GUI.SetApplicationResources(style);

4/ Run unity project
5/ Unity crashes
TagsNo tags attached.
PlatformWindows

Activities

Khonan

Khonan

2019-01-30 12:12

reporter  

MainWindow.xaml (1,342 bytes)
MainWindow.xaml.cs (2,628 bytes)
NocturnalStyle.xaml (295,596 bytes)
Khonan

Khonan

2019-01-30 15:22

reporter   ~0005430

After some investigations, I discovered all my troubles came from my inits not behing done during
OnInitialized(object sender, EventArgs args) ....

Causing random crash of unity..

Bug closed :)

Issue History

Date Modified Username Field Change
2019-01-30 12:12 Khonan New Issue
2019-01-30 12:12 Khonan File Added: MainWindow.xaml
2019-01-30 12:12 Khonan File Added: MainWindow.xaml.cs
2019-01-30 12:12 Khonan File Added: NocturnalStyle.xaml
2019-01-30 12:29 Khonan Description Updated View Revisions
2019-01-30 12:29 Khonan Steps to Reproduce Updated View Revisions
2019-01-30 15:22 Khonan Note Added: 0005430
2019-01-30 15:23 Khonan Summary Setting a fontfamily constant in a style makes unity Crash => Setting a fontfamily constant in a style makes unity Crash (fixed, not a bug)
2019-03-18 22:27 sfernandez Assigned To => sfernandez
2019-03-18 22:27 sfernandez Status new => assigned
2019-03-18 22:27 sfernandez Target Version => 2.2.1
2019-04-05 12:24 sfernandez Status assigned => resolved
2019-04-05 12:24 sfernandez Resolution open => no change required
2019-04-05 12:24 sfernandez Target Version 2.2.1 =>