View Issue Details

IDProjectCategoryView StatusLast Update
0001439NoesisGUIC++ SDKpublic2019-04-08 17:52
ReportersckrielAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.0 
Target Version2.2.2Fixed in Version2.2.2 
Summary0001439: LoadXAML crashes with DataTemplate as root element
DescriptionWe are storing DataTemplate and ControlTemplate in separate files that we load in the code behind. Sometimes this crashes. I have tested this in the XAML player too. Loading one file will lead to the "invalid root element" message, while another file will crash the XAML player. I have reduced the files that work and crashes to their simplest form and have deduced that the addition of resources for the DataTemplate makes it work. If no resources are defined, it crashes.
Steps To Reproduce1. Open XAML player.
2. Load DataTemplate _Works.xaml, it will work and report appropriate error message since the file cannot actually be viewed since it's a Data Template.
3. Load DataTemplate_Crashes.xaml, XAML Player crashes.
TagsNo tags attached.
PlatformWindows

Activities

sckriel

sckriel

2019-04-01 11:18

reporter  

DataTemplate_Crashes.xaml (237 bytes)
DataTemplate _Works.xaml (490 bytes)

Issue History

Date Modified Username Field Change
2019-04-01 11:18 sckriel New Issue
2019-04-01 11:18 sckriel File Added: DataTemplate_Crashes.xaml
2019-04-01 11:18 sckriel File Added: DataTemplate _Works.xaml
2019-04-05 12:01 sfernandez Assigned To => sfernandez
2019-04-05 12:01 sfernandez Status new => assigned
2019-04-05 12:03 sfernandez Target Version => 2.2.2
2019-04-05 12:03 sfernandez Description Updated View Revisions
2019-04-05 12:03 sfernandez Steps to Reproduce Updated View Revisions
2019-04-08 17:52 sfernandez Status assigned => resolved
2019-04-08 17:52 sfernandez Resolution open => fixed
2019-04-08 17:52 sfernandez Fixed in Version => 2.2.2