View Issue Details

IDProjectCategoryView StatusLast Update
0001450NoesisGUIUnity3Dpublic2019-08-17 00:24
ReportershawnAssigned Tojsantos 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version2.2.1 
Target VersionFixed in Version 
Summary0001450: Crash creating Unity render device
DescriptionFrom crashes posted in https://www.noesisengine.com/bugs/view.php?id=1429#c5620

In the first one the 'resource' pointer seems to be null.
The second callstack refers to a crash in Unity without Noesis being involved, but it could be related to the first crash.

 	Noesis.dll!SetDebugObjectName(ID3D11DeviceChild * resource, const char * str, ...) Line 117	C++
>	[Inline Frame] Noesis.dll!NoesisApp::D3D11RenderDevice::AllocatePage(NoesisApp::D3D11RenderDevice::DynamicBuffer &) Line 870	C++
     Noesis.dll!NoesisApp::D3D11RenderDevice::CreateBuffer(NoesisApp::D3D11RenderDevice::DynamicBuffer & buffer, unsigned int size, D3D11_BIND_FLAG flags, const char * label) Line 896	C++
     Noesis.dll!NoesisApp::D3D11RenderDevice::CreateBuffers() Line 909	C++
     Noesis.dll!NoesisApp::D3D11RenderDevice::D3D11RenderDevice(ID3D11DeviceContext * context, bool sRGB) Line 343	C++
     Noesis.dll!NoesisApp::D3D11Factory::CreateDevice(ID3D11DeviceContext * context, bool sRGB) Line 21	C++
     Noesis.dll!Noesis::UnityDeviceD3D11::UnityDeviceD3D11(IUnityInterfaces * unityInterfaces, bool sRGB) Line 38	C++
     [Inline Frame] Noesis.dll!`anonymous-namespace'::DeviceInitialize::__l5::<lambda_19a8d8fc18ebce0158ac87709b130cfd>::operator()() Line 155	C++
     Noesis.dll!<lambda_19a8d8fc18ebce0158ac87709b130cfd>::<lambda_invoker_cdecl>() Line 156	C++
     Noesis.dll!`anonymous namespace'::CreateDevice() Line 207	C++
     Noesis.dll!Noesis_GetRenderOffscreenCallback::__l2::<lambda>(int eventId, void * data) Line 391	C++
     Unity.exe!GfxDeviceWorker::RunCommand(ThreadedStreamBuffer & stream) Line 1551	C++
     [Inline Frame] Unity.exe!ProcessGfxCommands(GfxDeviceWorker &) Line 161	C++
     Unity.exe!GfxDeviceWorker::RunExt(ThreadedStreamBuffer & stream) Line 491	C++
     [Inline Frame] Unity.exe!GfxDeviceWorker::Run() Line 475	C++
     Unity.exe!GfxDeviceWorker::RunGfxDeviceWorker(void * data) Line 454	C++
     Unity.exe!Thread::RunThreadWrapper(void * ptr) Line 76	C++


 	Unity.exe!D3D11CommonShader::ApplyGpuProgram(const GpuProgramParameters & params, const unsigned char * buffer, bool bindCBs) Line 184	C++
>	Unity.exe!GfxDeviceD3D11Base::SetShadersThreadable(GpuProgram * * programs, const GpuProgramParameters * * params, const unsigned char * const * paramsBuffer) Line 1260	C++
     Unity.exe!GfxDeviceWorker::RunCommand(ThreadedStreamBuffer & stream) Line 772	C++
     [Inline Frame] Unity.exe!ProcessGfxCommands(GfxDeviceWorker &) Line 161	C++
     Unity.exe!GfxDeviceWorker::CallImmediate(ThreadedDisplayList * dlist) Line 363	C++
     Unity.exe!GfxDeviceWorker::RunCommand(ThreadedStreamBuffer & stream) Line 2004	C++
     [Inline Frame] Unity.exe!ProcessGfxCommands(GfxDeviceWorker &) Line 161	C++
     Unity.exe!GfxDeviceWorker::RunExt(ThreadedStreamBuffer & stream) Line 491	C++
     [Inline Frame] Unity.exe!GfxDeviceWorker::Run() Line 475	C++
     Unity.exe!GfxDeviceWorker::RunGfxDeviceWorker(void * data) Line 454	C++
     Unity.exe!Thread::RunThreadWrapper(void * ptr) Line 76	C++
TagsNo tags attached.
PlatformAny

Activities

jsantos

jsantos

2019-04-25 18:50

manager   ~0005643

I think this is probably not related to Noesis. It seems to be an out of memory or driver issue in the GPU. The second crash is not related to Noesis at all and the first one is a crash that's is happening when Noesis D3D11 is initialized and a buffer of 512KB for dynamic geometry is created but the driver returns a NULL pointer.

So, I think we should close this...

Issue History

Date Modified Username Field Change
2019-04-16 10:57 sfernandez New Issue
2019-04-16 10:58 sfernandez Assigned To => jsantos
2019-04-16 10:58 sfernandez Status new => assigned
2019-04-16 10:58 sfernandez Target Version => 2.2.2
2019-04-16 10:58 sfernandez Status assigned => resolved
2019-04-16 10:58 sfernandez Resolution open => fixed
2019-04-16 10:58 sfernandez Fixed in Version => 2.2.1
2019-04-16 10:59 sfernandez Status resolved => assigned
2019-04-16 10:59 sfernandez Fixed in Version 2.2.1 =>
2019-04-16 11:00 sfernandez Reporter sfernandez => shawn
2019-04-25 18:50 jsantos Status assigned => feedback
2019-04-25 18:50 jsantos Note Added: 0005643
2019-04-25 18:50 jsantos Product Version 2.2.0 => 2.2.1
2019-04-25 18:50 jsantos Target Version 2.2.2 =>
2019-08-17 00:24 jsantos Status feedback => resolved
2019-08-17 00:24 jsantos Resolution fixed => unable to reproduce