View Issue Details

IDProjectCategoryView StatusLast Update
0001453NoesisGUIC++ SDKpublic2019-04-24 12:15
ReportermingingminglerAssigned Tosfernandez 
Status feedbackResolutionopen 
Product Version2.2.1 
Target VersionFixed in Version 
Summary0001453: Minor inconsistency in naming convention in native API
DescriptionHi, was just integrating the native API into a project and noticed the following 3 lines in NsGui\Style.h:

typedef Noesis::UICollection<Noesis::BaseSetter> BaseSetterCollection;
typedef Noesis::UICollection<Noesis::BaseTrigger> TriggerCollection;
typedef Noesis::UICollection<Noesis::Condition> ConditionCollection;

It seems according to this convention, TriggerCollection should've been named BaseTriggerCollection. This may circumstantially conflict with TriggerCollection in the interactivity API. Fairly sure I spotted this in a couple other files but I forgot which ones they were. Not sure if a problem, thought I'd raise it anyway.
TagsNo tags attached.




2019-04-24 12:15

manager   ~0005639

Those names try to match WPF names:,8020cc19a945707b,dfc0f5bbfc1fa6bb,cab4a775ebf6bf82

Although it is true we should change some of our base class names in C++ API to exactly match WPF to avoid any confusion (we already did that in C# API):
BaseTrigger -> TriggerBase
BaseSetter -> SetterBase
BaseSetterCollection -> SetterBaseCollection
BaseButton -> ButtonBase

Issue History

Date Modified Username Field Change
2019-04-24 01:47 mingingmingler New Issue
2019-04-24 01:49 mingingmingler Description Updated View Revisions
2019-04-24 01:52 mingingmingler Description Updated View Revisions
2019-04-24 12:15 sfernandez Assigned To => sfernandez
2019-04-24 12:15 sfernandez Status new => feedback
2019-04-24 12:15 sfernandez Note Added: 0005639