View Issue Details

IDProjectCategoryView StatusLast Update
0001455NoesisGUIC# SDKpublic2019-04-25 19:24
Reporterdarthmaule2Assigned Tosfernandez 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.1 
Target Version2.2.2Fixed in Version2.2.2 
Summary0001455: BitmapImage support for spaces in path broken in 2.2.1
DescriptionPassing a path with a space to Noesis.BitmapImage results in FileTextureProvider::OpenStream called with %20
This use to work in 2.2.0, but is broken in 2.2.1
Steps To ReproduceCalling this:
Noesis.BitmapImage bitmapImage = new Noesis.BitmapImage(new Uri("C:\\Test Space\\image.bmp));

Results in a FileNotFoundException because the path provide by the FileTextureProvider converts the space to a %20
    public class FileSystemTextureProvider : FileTextureProvider
    {
        public FileSystemTextureProvider()
        {
        }

        public override Stream OpenStream(string path)
        {
            return new FileStream("C:\Test%20Space\image.bmp", FileMode.Open, FileAccess.Read); // Crash due to space converted to %20
        }
    }
TagsNo tags attached.
PlatformWindows

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-04-24 19:36 darthmaule2 New Issue
2019-04-25 18:20 sfernandez Assigned To => sfernandez
2019-04-25 18:20 sfernandez Status new => assigned
2019-04-25 18:22 sfernandez Target Version => 2.2.2
2019-04-25 19:24 sfernandez Status assigned => resolved
2019-04-25 19:24 sfernandez Resolution open => fixed
2019-04-25 19:24 sfernandez Fixed in Version => 2.2.2