View Issue Details

IDProjectCategoryView StatusLast Update
0001518NoesisGUIUnity3Dpublic2019-08-14 13:58
ReporterstonstadAssigned Tosfernandez 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Product Version2.2.3 
Target Version2.2.4Fixed in Version2.2.4 
Summary0001518: Assertion Failed, False at Vector.h 778
Description[noesis] Assertion failed: false, at vector.h(778)
UnityEngine.DebugLogHandler:Internal_Log(LogType, LogOption, String, Object)
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:LogError(Object)
NoesisUnity:UnityLog(Int32, String) (at Assets\NoesisGUI\Plugins\NoesisUnity.cs:116)
Noesis.View:Noesis_View_MouseMove(HandleRef, Int32, Int32)
Noesis.View:MouseMove(Int32, Int32) (at Assets\NoesisGUI\Plugins\API\Core\View.cs:114)
NoesisView:UpdateMouse() (at Assets\NoesisGUI\Plugins\NoesisView.cs:595)
NoesisView:UpdateInputs() (at Assets\NoesisGUI\Plugins\NoesisView.cs:721)
NoesisView:LateUpdate() (at Assets\NoesisGUI\Plugins\NoesisView.cs:753)
(Filename: Assets/NoesisGUI/Plugins/NoesisUnity.cs Line: 116)
Steps To ReproduceWas moving mouse across XAML UI elements. Exception from NoesisView.MouseMove.
TagsNo tags attached.
PlatformAny

Activities

stonstad

stonstad

2019-07-16 00:06

reporter  

Crash_2019-07-15_220007767.zip (653,862 bytes)
stonstad

stonstad

2019-07-27 04:34

reporter   ~0005910

I have not seen this error since I initially reported it on 7/15. I was using debug Noesis.dll builds. I am OK with closing this and I can report if it happens again.

Issue History

Date Modified Username Field Change
2019-07-16 00:06 stonstad New Issue
2019-07-16 00:06 stonstad File Added: Crash_2019-07-15_220007767.zip
2019-07-18 21:51 sfernandez Assigned To => sfernandez
2019-07-18 21:51 sfernandez Status new => assigned
2019-07-18 21:51 sfernandez Product Version 2.2.4 => 2.2.3
2019-07-18 21:51 sfernandez Target Version => 2.2.4
2019-07-18 21:51 sfernandez Description Updated View Revisions
2019-07-27 04:34 stonstad Note Added: 0005910
2019-08-14 13:58 sfernandez Status assigned => resolved
2019-08-14 13:58 sfernandez Resolution open => fixed
2019-08-14 13:58 sfernandez Fixed in Version => 2.2.4