View Issue Details

IDProjectCategoryView StatusLast Update
0001545NoesisGUIUnity3Dpublic2019-08-23 17:01
ReportersamcAssigned Tojsantos 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.2.3 
Target VersionFixed in Version 
Summary0001545: Unity 2019.1.14f1 HDRP new project doesn't render, causes errors
DescriptionNoesis samples don't work in Unity2019.1.14f1 and there are errors after importing the noesis package.

Also tested in 2019.2.2f1 and it has the same behavior
Steps To ReproduceCreate a new unity project using Unity 2019.1.14f1
Select "High Definition RP" for the template
Import the Noesis 2.2.3 package
Check the console and you'll see errors such as:

Read only asset Packages/com.unity.render-pipelines.high-definition/Runtime/Core/Debugging/Prefabs/Fonts/Perfect DOS VGA 437.asset has no meta file.
UnityEditor.AssetDatabase:CreateAsset(Object, String)
NoesisPostprocessor:ImportFont(String, Boolean) (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:139)
NoesisPostprocessor:ImportAssets(String[], UpdateProgress) (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:72)
NoesisPostprocessor:ImportAllAssets(UpdateProgress) (at Assets/NoesisGUI/Plugins/Editor/NoesisPostprocessor.cs:28)
NoesisUpdater:CheckVersion() (at Assets/NoesisGUI/Plugins/Editor/NoesisUpdater.cs:76)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions()


Open a Noesis Sample scene, "Buttons" for example
Click play
Observe:
 - you can hear sounds and mouse clicks register, but nothing is rendered on screen
TagsUnity
PlatformWindows

Activities

jsantos

jsantos

2019-08-22 23:30

manager   ~0005936

Just updated the title mentioning HDRP
jsantos

jsantos

2019-08-23 17:01

manager   ~0005938

For now, I am going to close this, because it is not a bug.

https://www.noesisengine.com/forums/viewtopic.php?f=3&t=1669

Let's continue the discussion at the forums.

Issue History

Date Modified Username Field Change
2019-08-22 20:33 samc New Issue
2019-08-22 20:33 samc Tag Attached: Unity
2019-08-22 23:26 jsantos Summary Unity 2019.1.14f1 new project doesn't render, causes errors => Unity 2019.1.14f1 HDRP new project doesn't render, causes errors
2019-08-22 23:30 jsantos Note Added: 0005936
2019-08-23 17:01 jsantos Assigned To => jsantos
2019-08-23 17:01 jsantos Status new => resolved
2019-08-23 17:01 jsantos Resolution open => no change required
2019-08-23 17:01 jsantos Note Added: 0005938