View Issue Details

IDProjectCategoryView StatusLast Update
0001694NoesisGUIC++ SDKpublic2020-05-28 16:28
ReporterstevehAssigned Tojsantos 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.0.0 
Target Version3.0.1Fixed in Version 
Summary0001694: Noesis::Symbol visualiser not working if building Noesis via static libs
DescriptionHi guys, just a tiny issue. We build Noesis as a static lib. It seems that when built like a static lib the *.natvis file does not display Symbols correctly:

<Type Name="Noesis::Symbol">
  <DisplayString>{{ {((const char**){,,Core.Noesis.Kernal.dll}gSymbols.mBegin)[mIndex],na} }}</DisplayString>
</Type>

<Type Name="Noesis::Symbol">
  <DisplayString>{{ {((const char**){,,Core.Noesis.Kernal.dll}gSymbols.mBegin)[mIndex],na} }}</DisplayString>
</Type>

The issue is the DLL reference. Dropping it so it just references gSymbols directly fixes it:

<Type Name="Noesis::Symbol">
  <DisplayString>{{ {((const char**)gSymbols.mBegin)[mIndex],na} }}</DisplayString>
</Type>

<Type Name="Noesis::Symbol">
  <DisplayString>{{ {((const char**)gSymbols.mBegin)[mIndex],na} }}</DisplayString>
</Type>



Just thought I'd mention it. This probably only affects us since I imagine most people are building Noesis via the DLL method. I've changed this locally in my visualiser so this is really low priority.

Cheers!
TagsNo tags attached.
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-05-23 18:00 steveh New Issue
2020-05-25 11:20 jsantos Assigned To => jsantos
2020-05-25 11:20 jsantos Status new => assigned
2020-05-25 11:20 jsantos Target Version => 3.0.1
2020-05-28 16:28 jsantos Status assigned => resolved
2020-05-28 16:28 jsantos Resolution open => fixed