View Issue Details

IDProjectCategoryView StatusLast Update
0001775NoesisGUIC# SDKpublic2020-08-12 13:29
Reporterck_russAssigned Tosfernandez 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.4 
Target Version3.0.5Fixed in Version3.0.5 
Summary0001775: Storyboard FillBehavior set in XAML is ignored by children
DescriptionHere is a XAMLToy ready code sample:

<Grid
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml">
  <Rectangle Width="50" Height="50" Fill="DarkSeaGreen">
    <Rectangle.Triggers>
      <EventTrigger RoutedEvent="Grid.Loaded">
        <BeginStoryboard>
          <Storyboard FillBehavior="Stop" Storyboard.TargetProperty="Width">
            <DoubleAnimation To="200" Duration="0:0:2"/>
          </Storyboard>
        </BeginStoryboard>
      </EventTrigger>
    </Rectangle.Triggers>
  </Rectangle>
</Grid>

In the above sample the animation should be ended after its execution due to FillBehavior=Stop, but it instead will hold it as if its FillBehavior was HoldEnd.
TagsStoryboard, xaml
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-08-11 07:16 ck_russ New Issue
2020-08-11 07:16 ck_russ Tag Attached: Storyboard
2020-08-11 07:16 ck_russ Tag Attached: xaml
2020-08-11 10:40 jsantos Target Version => 3.0.5
2020-08-11 10:40 jsantos Assigned To => sfernandez
2020-08-11 10:40 jsantos Status new => assigned
2020-08-12 13:29 sfernandez Status assigned => resolved
2020-08-12 13:29 sfernandez Resolution open => fixed
2020-08-12 13:29 sfernandez Fixed in Version => 3.0.5