View Issue Details

IDProjectCategoryView StatusLast Update
0001791NoesisGUIC++ SDKpublic2020-09-24 10:47
ReportersfernandezAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.4 
Target Version3.0.6Fixed in Version3.0.6 
Summary0001791: TextBox Foreground is sometimes ignored
DescriptionUsing the following TextBox template in Noesis:
<ControlTemplate x:Key="txt" TargetType="TextBox">
  <ScrollViewer x:Name="PART_ContentHost"/>
</ControlTemplate>


Then TextBox.Foreground property is ignored because the inner TextBoxView is inheriting the value from ScrollViewer control.

In WPF the Foreground property of the ScrollViewer inside TextBox template is not used by TextBoxView, and it always renders using TextBox.Foreground as expected.
TagsNo tags attached.
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-09-16 16:34 sfernandez New Issue
2020-09-16 16:34 sfernandez Assigned To => sfernandez
2020-09-16 16:34 sfernandez Status new => assigned
2020-09-16 16:34 sfernandez Target Version => 3.0.6
2020-09-24 10:47 sfernandez Status assigned => resolved
2020-09-24 10:47 sfernandez Resolution open => fixed
2020-09-24 10:47 sfernandez Fixed in Version => 3.0.6