View Issue Details

IDProjectCategoryView StatusLast Update
0001795NoesisGUIC++ SDKpublic2020-09-23 21:35
Reportertension_andreasAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.4 
Target Version3.0.6Fixed in Version3.0.6 
Summary0001795: When calling focus on a textbox the caret isn't showing and you can't write to the textbox
DescriptionSo I have a toggle button that toggles visibility of a TextBox between Visible and Collapsed
At the same time that i set the textbox to visible I also call Focus on it so you can immediately write in it on windows and on Android/iOS the keyboard should pop up.

This worked in 2.2.4 but since upgrading to noesis 3.0.4 this stopped working.
In 3.0.4 The textbox appears but it doesn't seem to be focused and the Caret i missing, On Android/iOS the keyboard isn't showing.

It only happens during the first toggle, the second time i shows the textbox with the caret as intended.

Has been happening on Windows, Android and iOS
Steps To ReproduceHave a togglebutton toggle a textbox like this
toggle->Click() += [this, toggle](BaseComponent*, const RoutedEventArgs&)
    {
        TextBox* searchBar = FindName<TextBox>("searchBar");
        if (toggle->GetIsChecked().GetValueOrDefault())
        {
            searchBar->SetVisibility(Visibility_Visible);
            searchBar->Focus();
        }
        else
        {
            searchBar->SetVisibility(Visibility_Collapsed);
        }
    };

A easy workaround for now is to call "UpdateLayout()" on the textbox before calling "Focus()"
TagsCaret, Focus, TextBox
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-09-23 12:16 tension_andreas New Issue
2020-09-23 12:16 tension_andreas Tag Attached: Caret
2020-09-23 12:16 tension_andreas Tag Attached: Focus
2020-09-23 12:16 tension_andreas Tag Attached: TextBox
2020-09-23 12:17 tension_andreas Description Updated View Revisions
2020-09-23 13:41 sfernandez Assigned To => sfernandez
2020-09-23 13:41 sfernandez Status new => assigned
2020-09-23 13:41 sfernandez Target Version => 3.0.6
2020-09-23 21:35 sfernandez Status assigned => resolved
2020-09-23 21:35 sfernandez Resolution open => fixed
2020-09-23 21:35 sfernandez Fixed in Version => 3.0.6