View Issue Details

IDProjectCategoryView StatusLast Update
0001876NoesisGUIUnrealpublic2021-01-07 18:58
ReportersfernandezAssigned Tohcpizzi 
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version3.0.8 
Target Version3.0.9Fixed in Version3.0.9 
Summary0001876: LoadTexture crash in Unreal because it uses LoadObject in render thread
DescriptionThere is a crash on LoadTexture and GetTexture with a message:
 > Unable to load /NTUI/Interface/Assets/ConstructionImages/DotGrid2x2_40x40. Objects and Packages can only be loaded from the game thread.

Here is a callstack:
> UE4Editor-CoreUObject.dll!LoadPackageInternal() Line 1066      C++
  UE4Editor-CoreUObject.dll!LoadPackage() Line 1427              C++
  UE4Editor-CoreUObject.dll!ResolveName() Line 767          C++
  UE4Editor-CoreUObject.dll!StaticLoadObjectInternal() Line 829        C++
  UE4Editor-CoreUObject.dll!StaticLoadObjectInternal() Line 880        C++
  UE4Editor-CoreUObject.dll!StaticLoadObject() Line 904        C++
  [Inline Frame] UE4Editor-NoesisRuntime.dll!LoadObject() Line 1327      C++
  UE4Editor-NoesisRuntime.dll!FNoesisTextureProvider::GetTexture() Line 72 C++
  UE4Editor-NoesisRuntime.dll!FNoesisTextureProvider::LoadTexture() Line 94   C++
  [External Code]
  UE4Editor-NoesisRuntime.dll!UNoesisInstance::NativePaint::__l5::<lambda>() Line 651      C++
  ...


It looks that the crash is caused by referencing an image that has been unloaded to GC.

The issue is only happening in Standalone version and not in PIE
TagsNo tags attached.
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-01-07 18:56 sfernandez New Issue
2021-01-07 18:56 sfernandez Status new => assigned
2021-01-07 18:56 sfernandez Assigned To => hcpizzi
2021-01-07 18:57 sfernandez Target Version => 3.0.9
2021-01-07 18:58 sfernandez Status assigned => resolved
2021-01-07 18:58 sfernandez Resolution open => fixed
2021-01-07 18:58 sfernandez Fixed in Version => 3.0.9