View Issue Details

IDProjectCategoryView StatusLast Update
0001883NoesisGUIC++ SDKpublic2021-02-09 21:01
ReportersfernandezAssigned Tojsantos 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.9 
Target Version3.0.10Fixed in Version3.0.10 
Summary0001883: Touch capture not released when cancelling ManipulationStarted
DescriptionIf a element sets IsManipulationEnabled to true and in its ManipulationStarted cancels it, the touch is still captured by the element, so TouchMove and TouchUp events are only sent to that element.

This can be reproduced in our application framework, because our Window uses manipulations to show the stats/debug toolbar, but touching in the middle of the window shouldn't capture anything.
TagsNo tags attached.
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-01-15 13:19 sfernandez New Issue
2021-01-15 13:19 sfernandez Assigned To => jsantos
2021-01-15 13:19 sfernandez Status new => assigned
2021-01-15 13:19 sfernandez Product Version => 3.0.9
2021-01-15 13:19 sfernandez Target Version => 3.0.10
2021-02-09 21:01 jsantos Status assigned => resolved
2021-02-09 21:01 jsantos Resolution open => fixed
2021-02-09 21:01 jsantos Fixed in Version => 3.0.10