View Issue Details

IDProjectCategoryView StatusLast Update
0002063NoesisGUIC++ SDKpublic2021-08-04 16:31
Reportersteveh Assigned Tosfernandez  
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version3.0.9 
Target Version3.1.1Fixed in Version3.1.1 
Summary0002063: Assert when stopping storyboard
DescriptionHi guys, we're hitting an assert in TimeManager::OnClockFinished in rare cases when stopping a storyboard.

The assert is in the following line:

                if (clocks.Empty())
                {
                    // Clear any pending animation related with this target and dp
                    RemovePendingAnimation(target, dp);

                    // Clear animated property
                    animatedProperties.Erase(propIt); <<<<<<<<<<<<<<< HERE
                }


(Line 813 in version 3.0.9). The issue is that propIt is no longer valid. The animatedProperties map is empty so something must have removed the properties in between line 784 when it finds the dependency property and line 813 when it tries to erase it.

I can change the line to this instead so it doesn't rely on the iterator remaining valid:

animatedProperties.Erase(dp);

Cheers,

-Steven
Steps To Reproduce- Stop a storyboard
- In rare cases it can assert.
TagsNo tags attached.
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-07-23 13:46 steveh New Issue
2021-08-02 13:17 sfernandez Assigned To => sfernandez
2021-08-02 13:17 sfernandez Status new => assigned
2021-08-02 13:17 sfernandez Target Version => 3.1
2021-08-04 13:09 sfernandez Status assigned => resolved
2021-08-04 13:09 sfernandez Resolution open => fixed
2021-08-04 13:09 sfernandez Fixed in Version => 3.1
2021-08-04 16:31 sfernandez Fixed in Version 3.1 => 3.1.1
2021-08-04 16:31 sfernandez Target Version 3.1 => 3.1.1