View Issue Details

IDProjectCategoryView StatusLast Update
0002093NoesisGUIC++ SDKpublic2021-12-02 18:08
Reporterjsantos Assigned Tojsantos  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.0 
Target Version3.1.2Fixed in Version3.1.2 
Summary0002093: Switch to DXC shader compiler for Xbox One and Xbox Series
DescriptionShader compiling at runtime is taking seconds on both Xbox One and Xbox Series, we should switch to the recommended DXC compiler for these platforms.

Right now, this is not as trivial as it sounds because we need to specify the root signature in each shaders and right now that information is available at compile time in the C++ source.
TagsNo tags attached.
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-08-26 17:36 jsantos New Issue
2021-08-26 17:36 jsantos Assigned To => jsantos
2021-08-26 17:36 jsantos Status new => assigned
2021-08-26 17:36 jsantos Target Version => 3.1.1
2021-09-15 20:56 jsantos Target Version 3.1.1 => 3.1.2
2021-12-02 18:08 jsantos Status assigned => resolved
2021-12-02 18:08 jsantos Resolution open => fixed
2021-12-02 18:08 jsantos Fixed in Version => 3.1.2