View Issue Details

IDProjectCategoryView StatusLast Update
0002378NoesisGUIUnity3Dpublic2022-07-13 13:24
Reporterpeter_e-h_easylaser Assigned Tosfernandez  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.1.5 
Target Version3.1.6Fixed in Version3.1.6 
Summary0002378: Noesis 3.1.5 Unity release doesn't work when uploaded to a UPM (npm) pagacke repository.
DescriptionThe files in the API folder (and possibly others) are missing their .meta files, so the 3.1.5 release won't work when we push it to our npm repository and add it through Unity Package Manager.
It would be preferrable to be able to do this instead of including the package in our main repository, as it keeps our main repository smaller, and makes upgrading to a newer version easier.
Steps To Reproduce* Use "npm publish" to push the 3.1.5 Unity release to a repository
* Add the repository and package reference to a Unity project
= The files in the Runtime/API folder are unavailable to Unity since there are no .meta files associated.
TagsNo tags attached.
PlatformAny

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2022-07-13 10:26 peter_e-h_easylaser New Issue
2022-07-13 11:07 sfernandez Assigned To => sfernandez
2022-07-13 11:07 sfernandez Status new => assigned
2022-07-13 11:07 sfernandez Target Version => 3.1.6
2022-07-13 13:24 sfernandez Status assigned => resolved
2022-07-13 13:24 sfernandez Resolution open => fixed
2022-07-13 13:24 sfernandez Fixed in Version => 3.1.6