k.halterman13
Topic Author
Posts: 2
Joined: 12 Mar 2017, 06:21

Cannot search forums / Blend XAML errors

19 Mar 2017, 19:02

Anyone know how to get the search engine to work? I tried "Blend UserControl is not supported" after getting this error from reloading a xaml into blend that was removed somehow when Noesis updated the .asset. The search just returns with the error "Blend UserControl is not supported" keywords were not included because they were too common words. I feel that search term was pretty specific.

Otherwise, I'll just ask the question here.

I am just getting started with NoesisGUI and using Blend to open the .sln files to edit my .xaml's as well as editing my .cs files (instead of monodevelop). I made a simple UI file, nothing works yet, just getting to know the editor. Opened it in Unity, Noesis created the .asset and I attached that to the camera. Everything looked fine on play. Now Blend has removed the .xaml from the solution hierarchy, so when I tried to add existing file to re-add it, it has given me 41 errors saying that it's not a valid xaml file. And the visual editor just shows an 'Invalid Markup' error. Examples of the errors are:

Severity Code Description Project File Line Suppression State
Error UserControl is not supported in a Windows Presentation Foundation (WPF) project. Assembly-CSharp C:\Projects\Unity\Project1\Assets\_UI Assets\Controls\HUDControl.xaml 1

Severity Code Description Project File Line Suppression State
Error The type 'UserControl' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built. Assembly-CSharp C:\Projects\Unity\Project1\Assets\_UI Assets\Controls\HUDControl.xaml 1


How do I get Unity and Blend to work together to prevent this? I have Unity's external editor set to Monodevelop just for creating the VS solution and I am using VS 2017 Community with literally every feature installed. Thanks in advance.

EDIT: I got it to load properly after creating a new UserControl asset. Now I am just trying to figure out how to get whatever .dll loaded/initialized to do so on project open/startup....
 
User avatar
sfernandez
Site Admin
Posts: 1912
Joined: 22 Dec 2011, 19:20

Re: Cannot search forums / Blend XAML errors

20 Mar 2017, 20:17

Hi,

We have adjusted search settings and recreated search index and now it seems to behave better. The problem was that a lot of words were marked since the very beginning as common, and that appears to remain as this forever unless search index is recreated.

Regarding Blend/Unity workflow we suggest the following: viewtopic.php?f=3&t=1012#p5550

The idea is to have a project in Blend where you add and edit the UserControls (and other xamls) under an Assets folder. Blend project (.csproj) should be different from the one created by Unity in order to work correctly in Blend.

Who is online

Users browsing this forum: No registered users and 0 guests