User avatar
horeaper
Topic Author
Posts: 32
Joined: 22 Sep 2014, 12:50

IME doesn't work in Unity Windows build (2.1.0f1)

25 Mar 2018, 06:30

Typing chinese/japanese characters using IME inside TextBox doesn't work with Windows build, both in editor and build result.
It feels like keystrokes get send directly to TextBox, IME doesn't get a chance to process them.

However the Login sample from native SDK works fine, as this screenshot shows:
IME_with_NativeSDK.jpg
Suggests that Noesis TextBox actually supports IME, it may just something get messed up while integrated into Unity.
 
User avatar
jsantos
Site Admin
Posts: 2904
Joined: 20 Jan 2012, 17:18
Contact:

Re: IME doesn't work in Unity Windows build (2.1.0f1)

27 Mar 2018, 10:52

This seems to be a limitation of the current implementation. Could you please report about it? Thanks
 
User avatar
horeaper
Topic Author
Posts: 32
Joined: 22 Sep 2014, 12:50

Re: IME doesn't work in Unity Windows build (2.1.0f1)

27 Mar 2018, 12:45

This seems to be a limitation of the current implementation. Could you please report about it? Thanks
Done: https://www.noesisengine.com/bugs/view.php?id=1264

This is the first time I ever used the issue tracker, hopefully I didn't do something wrong ^_^
 
User avatar
jsantos
Site Admin
Posts: 2904
Joined: 20 Jan 2012, 17:18
Contact:

Re: IME doesn't work in Unity Windows build (2.1.0f1)

27 Mar 2018, 12:48

Perfectly reported! Thanks a lot for your feedback.

Who is online

Users browsing this forum: No registered users and 1 guest