User avatar
stonstad
Topic Author
Posts: 133
Joined: 06 Jun 2016, 18:14
Location: Lesser Magellanic Cloud
Contact:

Visual Studio 2017 Designer Support

28 Feb 2019, 20:01

I am using Unity and most of my development is inside Visual Studio. When I edit a XAML file I get warnings for the noesis namespace classes. Is there an easy way to remove these warnings and retain tab-completion?

Here are things I tried:
  • Change the build type to 'none'.
    Add a noesis namespace which points to the clr library.
    Edit via a different program -- which defeats the purpose of having an IDE.
Image

Any thoughts around how to fix this? Not really looking for suggestions on different editors besides VS.

Tags:
 
User avatar
sfernandez
Site Admin
Posts: 1915
Joined: 22 Dec 2011, 19:20

Re: Visual Studio 2017 Designer Support

01 Mar 2019, 13:11

This might happen if you use the Visual Studio project generated by Unity, right?
I suggest you follow the approach exposed in this tutorial https://www.noesisengine.com/docs/Gui.C ... unity.html, the idea is having a different project to edit xamls in Visual Studio Blend, so you can even see the preview before you play the scene in Unity.

Please let us know if you need help on setting up that.
 
User avatar
stonstad
Topic Author
Posts: 133
Joined: 06 Jun 2016, 18:14
Location: Lesser Magellanic Cloud
Contact:

Re: Visual Studio 2017 Designer Support

02 Mar 2019, 07:43

Thank you for your helpful response!
 
User avatar
jsantos
Site Admin
Posts: 2905
Joined: 20 Jan 2012, 17:18
Contact:

Re: Visual Studio 2017 Designer Support

02 Mar 2019, 13:46

All our Unity samples follow that approach, they have the Blend project next to the /Assets folder.

Who is online

Users browsing this forum: Bing [Bot] and 0 guests