kaban
Topic Author
Posts: 17
Joined: 22 Sep 2013, 09:35

Interesting behaviour in scrollviewarea, any work around?

26 Sep 2013, 15:42

I tried to file a bug report for this but got an error saying I'm not allowed to post bug reports saying:
Forbidden

You don't have permission to access /bugs/bug_report.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
:(

I'll post the bug report here for now and hopefully get some insight into it...

Summary:

Scrollview area does not clip children properly

In the Unity editor where the editor 'game' window is docked in the main unity window scrollview area does not clip children, however if the window is taken outside of the main editor window scrollviewarea does clip children

Steps To Reproduce:

Create scroll view area, place grid inside it, this is the xaml:
xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
xmlns:MyControl="clr-namespace:MyControl"
xmlns:UpgradeUI="clr-namespace:UpgradeUI" xmlns:GameUI="clr-namespace:GameUI"
mc:Ignorable="d"
Height="100"
Width="300"
x:Name="ButtonScrollArea"
>
    <Grid x:Name="Buttons" />
</ScrollViewer>
Attach the following C# script to the camera which has the NoesisGUIPanel Component attached:
using UnityEngine;
using System.Collections;
using Noesis;
using UnityEditor;

public class TestNoe : MonoBehaviour
{
    void Awake()
    {
        var gui = GetComponent<NoesisGUIPanel>();
        var root = gui.GetRoot<FrameworkElement>();

        Grid g = root.FindName<Grid>("Buttons");

        for (int i = 0; i < 10; i++)
        {
            Noesis.Button b = new Noesis.Button();
            b.SetContent("TEST");
            b.SetHeight(30);
            b.SetWidth(100);
            b.SetVerticalAlignment(VerticalAlignment.Top);
            b.SetMargin(new Thickness(0, i * 30, 0, 0));
            g.GetChildren().Add(b);
        }
    }
}
Screenshot of issue: http://i.imgur.com/XYEojTe.png


I'm not sure how far ranging this problem is, if it will happen in deployed applications or if it only happens when the Unity 'game' window is docked in the main Unity editor window..
 
User avatar
sfernandez
Site Admin
Posts: 1918
Joined: 22 Dec 2011, 19:20

Re: Interesting behaviour in scrollviewarea, any work around

26 Sep 2013, 20:38

The xaml seems to be incomplete... the root is a ScrollViewer object?
 
User avatar
jsantos
Site Admin
Posts: 2906
Joined: 20 Jan 2012, 17:18
Contact:

Re: Interesting behaviour in scrollviewarea, any work around

26 Sep 2013, 22:55

I tried to file a bug report for this but got an error saying I'm not allowed to post bug reports saying:
We are having troubles with our hosting sever. They decided to install mod_security without asking... :evil: We are working to find a solution.

Thanks!
 
User avatar
jsantos
Site Admin
Posts: 2906
Joined: 20 Jan 2012, 17:18
Contact:

Re: Interesting behaviour in scrollviewarea, any work around

27 Sep 2013, 17:34

Problems with the bugtracker have been fixed.

Could you report this bug please?
 
kaban
Topic Author
Posts: 17
Joined: 22 Sep 2013, 09:35

Re: Interesting behaviour in scrollviewarea, any work around

27 Sep 2013, 19:30

The xaml seems to be incomplete... the root is a ScrollViewer object?
Yes it's a ScrollViewer, the <ScrollViewer> tag is missing from the top part :oops:

I've submitted a bug report.
 
User avatar
sfernandez
Site Admin
Posts: 1918
Joined: 22 Dec 2011, 19:20

Re: Interesting behaviour in scrollviewarea, any work around

07 Oct 2013, 14:52

I requested some feedback from you in the bug tracker. We will continue analysing this problem there.
Thanks for your collaboration.

Who is online

Users browsing this forum: Google [Bot] and 1 guest