shadowmage45
Topic Author
Posts: 4
Joined: 27 Feb 2019, 20:03

Unity Version Requirement

19 Mar 2019, 17:57

Hi All;

Was wondering what version of Unity the current releases are intended to work with? Is there an 'older downloads' section to get releases compatible with older versions of Unity (understanding there will be no support)?

I've tried using the 2.2 releases with a Unity 2017.1.x project, but get errors after import on quite a few scripts as they appear to be referencing non-existent Unity classes/members. I'm not currently able to upgrade the version of Unity that is used by the project due to external requirements (though if it is a requirement for use of Noesis, I might be able to push for an upgrade based on that).

Thanks;

Tags:
 
User avatar
sfernandez
Site Admin
Posts: 1918
Joined: 22 Dec 2011, 19:20

Re: Unity Version Requirement

19 Mar 2019, 23:36

Hi, I've just tried NoesisGUI 2.2 package in Unity 2017 LTS (https://unity3d.com/unity/qa/lts-releases?page=1) and apart from one of our samples using in a couple of places the C# null-conditional operator (that can be easily fixed using an if), the rest of scripts compile just fine.

Is not possible to you to move your game to Unity 2017.4.x LTS?
What are the list of compiler errors you are getting? maybe there is an easy way to solve them and we can include them with conditional compilation in the next release.
 
User avatar
jsantos
Site Admin
Posts: 2906
Joined: 20 Jan 2012, 17:18
Contact:

Re: Unity Version Requirement

20 Mar 2019, 02:53

Just to clarify, Unity 2017.4.x LTS is the lowest version we support in NoesisGUI 2.2, we will fix the problems found in the inventory sample.
 
shadowmage45
Topic Author
Posts: 4
Joined: 27 Feb 2019, 20:03

Re: Unity Version Requirement

20 Mar 2019, 15:43

Understood, thanks for the confirmation. I will investigate other options for the time being.

My initial project is for UI creation for mods for Kerbal Space Program. The game is unfortunately still using 2017.1p3, and I have to use the same editor version as the released game in order to compile shaders that are compatible. Will check back in here if/when KSP decides to get with modern times.
 
User avatar
jsantos
Site Admin
Posts: 2906
Joined: 20 Jan 2012, 17:18
Contact:

Re: Unity Version Requirement

20 Mar 2019, 16:39

You still can use 2.1, it can be downloaded from here. We are going to upload this version to the Unity Asset Store later today.

Who is online

Users browsing this forum: No registered users and 1 guest