User avatar
HardlineStudios
Topic Author
Posts: 4
Joined: 16 Oct 2015, 23:21
Contact:

Blend for Visual Studio 2017 Issues

28 Apr 2020, 00:42

Hey guys, just getting started with this wonderful SDK but have run into some issues with getting Blend to properly work with samples. It doesn't happen with all of them but for a lot of them, when I open the blend project and view the design mode, I get invalid markup errors.

In this case, I had tried opening QuestLog-blend.csproj in Src\Packages\Samples\QuestLog\Data and this is what I'm seeing:
https://i.imgur.com/dUj2U2C.jpg

(sorry this forum won't let me upload images for some reason)

I can get it to work if I comment things out as seen in the image but obviously that's not the preferred method. I tried changing target SDK's but wasn't very successful there either.

Any ideas?

Tags:
 
jinfox
Posts: 9
Joined: 06 Apr 2019, 00:11

Re: Blend for Visual Studio 2017 Issues

28 Apr 2020, 10:43

Hello,

You might be missing an extension on your Blend for Visual studio software.
https://www.nuget.org/packages/Noesis.GUI.Extensions/

Can you make sure that you have this Nuget Package installed?
 
User avatar
HardlineStudios
Topic Author
Posts: 4
Joined: 16 Oct 2015, 23:21
Contact:

Re: Blend for Visual Studio 2017 Issues

28 Apr 2020, 19:23

Thanks for the reply.

I just did a quick check and I already had that extension installed.
 
User avatar
sfernandez
Site Admin
Posts: 1920
Joined: 22 Dec 2011, 19:20

Re: Blend for Visual Studio 2017 Issues

28 Apr 2020, 21:58

Could you please verify that you don't have in your Blend project a reference to System.Windows.Interactivity and/or Microsoft.Expression.Interactions assemblies. You should have a reference to Noesis.GUI.Extensions nuget but not those. Also make sure you are using PackageReference for nuget "Default package management format".

If that doesn't help, please try the solution from https://stackoverflow.com/questions/320 ... -is-not-su

Using the Nuget should avoid those problems, but maybe I'm missing something.
 
User avatar
HardlineStudios
Topic Author
Posts: 4
Joined: 16 Oct 2015, 23:21
Contact:

Re: Blend for Visual Studio 2017 Issues

29 Apr 2020, 05:46

Could you please verify that you don't have in your Blend project a reference to System.Windows.Interactivity and/or Microsoft.Expression.Interactions assemblies. You should have a reference to Noesis.GUI.Extensions nuget but not those. Also make sure you are using PackageReference for nuget "Default package management format".
The references you mentioned were there so I deleted them and now I have these errors for missing references:
Image

Which resulted in all sorts of errors for missing references to EventTrigger and StoryBoard.

For brevity, I am working with the QuestLog sample that was packed with the Neosis 2.2.6 SDK in Visual Studio Blend 2017 (Version 15.9.22)
 
User avatar
sfernandez
Site Admin
Posts: 1920
Joined: 22 Dec 2011, 19:20

Re: Blend for Visual Studio 2017 Issues

29 Apr 2020, 10:32

I want to share the steps I followed to see if there is something different in your setup.

I have Visual Studio Profesional 2017 v15.9.22, with NuGet Package Manager 4.6.0 (this info is shown in the about window).

1. Download NativeSDK 2.2.6 from our downloads page.
2. Go to Src/Packges/Samples/QuestLog/Data
3. Open QuestLog-blend.csproj
4. Save the generated solution QuestLog-blend.sln in the same directory. You need to do this before the Nuget package Restore, otherwise Visual Studio complains with this message:
Solution is not saved. Please save your solution before managing NuGet packages.
5. Now right click in your Solution and select "Restore NuGet Packages". Expand References to see if Noesis.GUI.Extensions is being installed, and as an extra check show the properties of Noesis.GUI.Extensions, Microsoft.Expression.Interactions and System.Windows.Interactivity to see if they point to the assemblies downloaded in the "packages" folder next to the solution.
6. Build the project.
7. Open MainWindow.xaml and everything should show correctly.

Please try this steps with a clean download of the SDK first, or with another project. If this works we would like to do some more tests with the failing project you have now to figure out what could be happening.
 
User avatar
HardlineStudios
Topic Author
Posts: 4
Joined: 16 Oct 2015, 23:21
Contact:

Re: Blend for Visual Studio 2017 Issues

30 Apr 2020, 19:57

Ok so followed all those steps and it built fine, package references are where they should be but when I go to view the XAML in design mode I get these errors:
Severity	Code	Description	Project	File	Line	Suppression State
Error	XDG0060	The type 'EventTrigger' from assembly 'System.Windows.Interactivity' is built with an older version of the Blend SDK, and is not supported in a Windows Presentation Framework 4 project.	QuestLog-blend	MainWindow.xaml	144	
Error	XDG0044	The local property "Actions" can only be applied to types that are derived from "TriggerBase".	QuestLog-blend	MainWindow.xaml	285	
Error	XDG0060	The type 'EventTrigger' from assembly 'System.Windows.Interactivity' is built with an older version of the Blend SDK, and is not supported in a Windows Presentation Framework 4 project.	QuestLog-blend	MainWindow.xaml	285	
Error	XDG0044	The local property "Actions" can only be applied to types that are derived from "TriggerBase".	QuestLog-blend	MainWindow.xaml	301	
Error	XDG0060	The type 'EventTrigger' from assembly 'System.Windows.Interactivity' is built with an older version of the Blend SDK, and is not supported in a Windows Presentation Framework 4 project.	QuestLog-blend	MainWindow.xaml	301	
Error	XDG0044	The local property "Actions" can only be applied to types that are derived from "TriggerBase".	QuestLog-blend	MainWindow.xaml	311	
Error	XDG0060	The type 'EventTrigger' from assembly 'System.Windows.Interactivity' is built with an older version of the Blend SDK, and is not supported in a Windows Presentation Framework 4 project.	QuestLog-blend	MainWindow.xaml	311	
Using Visual Studio Community 2017 is the only difference.. wonder if that makes a difference?

Who is online

Users browsing this forum: No registered users and 0 guests