asusralis
Topic Author
Posts: 85
Joined: 30 Jul 2018, 05:03

Text not being rendered in new UE project.

21 Jun 2020, 19:23

I'm on 4.24.3 & 3.0.2. Rectangles, images, etc show but text never does. I'm using the default settings including font and resources.

I'm able to crash the editor by typing into a TextBox. I attached the log files of the crash.
Attachments
UE4CC-Windows-344040564D3DB69523BF2CA4B9B6D76D_0001.rar
(84.18 KiB) Downloaded 17 times
 
User avatar
hcpizzi
Site Admin
Posts: 236
Joined: 09 Feb 2012, 12:40

Re: Text not being rendered in new UE project.

22 Jun 2020, 11:20

Hi asuralis,

Could you please send us the sample project you're using? We had already identified the cause of the crash, and a fix will be on our next release. But the Unreal project would come in handy to verify the other issue.

Thank you.
 
User avatar
sfernandez
Site Admin
Posts: 1918
Joined: 22 Dec 2011, 19:20

Re: Text not being rendered in new UE project.

22 Jun 2020, 13:04

Before getting the whole project, some questions.
Do you have a font set in NoesisGUI plugin settings? By default Noesis plugin has a reference to theme's PT_Root_UI_Font.
Did you set FontFamily in xaml to any StaticResource or local value? Can you share how?
Did you get any errors in the output log about missing fonts?

Thanks for your collaboration.
 
asusralis
Topic Author
Posts: 85
Joined: 30 Jul 2018, 05:03

Re: Text not being rendered in new UE project.

22 Jun 2020, 18:02

No, I didn't do any of that. I added the Noesis plugin, created a blend project, mapped its directory to one in my UE project, and created a new XAML. The font is PT_Root_UI_Font and this is the XAML:
<UserControl
    x:Class="Blend.Controls.GameHUD"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
    xmlns:local="clr-namespace:Blend.Controls"
    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
    mc:Ignorable="d"
    d:DesignWidth="800"
    d:DesignHeight="450">
    <Grid>
        <TextBox VerticalAlignment="Top" />
        <TextBlock
            HorizontalAlignment="Center"
            VerticalAlignment="Center"
            FontSize="60"
            Text="Hello, world!" />

    </Grid>
</UserControl>
I did upgrade the project from 4.22 to 4.24, but I think that was before adding Noesis.
 
User avatar
sfernandez
Site Admin
Posts: 1918
Joined: 22 Dec 2011, 19:20

Re: Text not being rendered in new UE project.

23 Jun 2020, 13:44

Thanks for the explanation, I was able to reproduce the issue and we are investigating.

Who is online

Users browsing this forum: No registered users and 1 guest