descala
Topic Author
Posts: 15
Joined: 19 Sep 2013, 20:11

Textbox issues using Ogre bindings

02 Dec 2013, 23:13

Hello,

I am having some trouble getting textboxes to accept input properly when using the Ogre bindings. Specifically, backspace doesn't appear to delete characters from the textbox. Because of this, the number of keystrokes the textbox will accept is limited to the MaxLength attribute value.

Am I doing something wrong, or is this a known issue?

Thanks!

Here is the relevant xaml:

<TextBox x:Name="TextBoxSMapIdealValue" HorizontalAlignment="Center" Height="21" Margin="0,0,0,8" TextWrapping="Wrap" VerticalAlignment="Bottom" Width="38.5" MaxLength="3" Background="#FF4E4E4E" Foreground="White" Text="0" FontSize="10.667">
	<TextBox.BorderBrush>
		<LinearGradientBrush EndPoint="0,20" MappingMode="Absolute" StartPoint="0,0">
			<GradientStop Color="White"/>
			<GradientStop Color="White" Offset="1"/>
		</LinearGradientBrush>
	</TextBox.BorderBrush>
</TextBox>
 
User avatar
sfernandez
Site Admin
Posts: 1911
Joined: 22 Dec 2011, 19:20

Re: Textbox issues using Ogre bindings

03 Dec 2013, 18:40

Hi,

We just tried with the latest Ogre Bindings and it is working.
Can you confirm us you are using also the latest bindings?

We added a table for correctly converting Ogre key codes to noesisGUI key codes two months ago. We discussed about this change here: viewtopic.php?f=3&t=138
 
descala
Topic Author
Posts: 15
Joined: 19 Sep 2013, 20:11

Re: Textbox issues using Ogre bindings

03 Dec 2013, 19:11

Ah, I found I was using an old version of the bindings. Updating fixed it! Thanks!

Who is online

Users browsing this forum: No registered users and 0 guests