g33rt
Topic Author
Posts: 23
Joined: 14 Jan 2014, 16:02

upgrading to 1.1.9

01 Jul 2014, 15:58

I've just installed 1.1.9

I get following exceptions, anyone else?

DllNotFoundException: NoesisUnityRenderHook
NoesisGUISystem.HookUnityGraphicsDeviceDesktop () (at Assets/Plugins/NoesisGUI/Scripts/Core/NoesisGUISystem.cs:165)
NoesisGUISystem.HookUnityGraphicsDevice () (at Assets/Plugins/NoesisGUI/Scripts/Core/NoesisGUISystem.cs:158)
NoesisGUISystem.Init () (at Assets/Plugins/NoesisGUI/Scripts/Core/NoesisGUISystem.cs:105)
NoesisGUISystem.Awake () (at Assets/Plugins/NoesisGUI/Scripts/Core/NoesisGUISystem.cs:58)
UnityEngine.GameObject:AddComponent()
NoesisGUISystem:Create() (at Assets/Plugins/NoesisGUI/Scripts/Core/NoesisGUISystem.cs:23)
NoesisGUIPanel:OnEnable() (at Assets/Plugins/NoesisGUI/Scripts/NoesisGUIPanel.cs:62)



NullReferenceException: Object reference not set to an instance of an object
Noesis.Extend.Noesis_InstantiateExtend (IntPtr unityType) (at Assets/Plugins/NoesisGUI/Scripts/Core/NoesisExtendImports.cs:88)
Noesis.Extend.New (System.Type type, Noesis.BaseComponent instance) (at Assets/Plugins/NoesisGUI/Scripts/Core/NoesisExtend.cs:1139)
Noesis.BaseComponent.CreateCPtr (System.Type type) (at Assets/Plugins/NoesisGUI/Scripts/Proxies/BaseComponentExtend.cs:40)
Noesis.BaseComponent..ctor () (at Assets/Plugins/NoesisGUI/Scripts/Proxies/BaseComponentExtend.cs:15)
GameOverviewUi.LocalisationHelper..ctor ()
GameOverviewUi.LocalisationHelper..cctor () (at Assets/GameOverviewUi/Helpers/LocalisationHelper.cs:26)
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for GameOverviewUi.LocalisationHelper
GameOverviewUi.Main+<Start>c__Iterator8.MoveNext () (at Assets/GameOverviewUi/Main.cs:22)
 
User avatar
jsantos
Site Admin
Posts: 2904
Joined: 20 Jan 2012, 17:18
Contact:

Re: upgrading to 1.1.9

01 Jul 2014, 16:05

Upgrading or new install? Windows or OSX?

We had to rename the library UnityRenderHook to NoesisUnityRenderHook to avoid conflicts with other third parties.
 
g33rt
Topic Author
Posts: 23
Joined: 14 Jan 2014, 16:02

Re: upgrading to 1.1.9

01 Jul 2014, 16:14

Imported as Custom Package in Unity on Mac OSX on top of the previous one
 
User avatar
jsantos
Site Admin
Posts: 2904
Joined: 20 Jan 2012, 17:18
Contact:

Re: upgrading to 1.1.9

01 Jul 2014, 16:21

You should have that library (NoesisUnityRenderHook.bundle) at the following location: $PROJECT/Assets/Plugins

Could you please verify it?
 
g33rt
Topic Author
Posts: 23
Joined: 14 Jan 2014, 16:02

Re: upgrading to 1.1.9

01 Jul 2014, 16:25

No, it's not there (I see the old one "UnityRenderHook.bundle")
 
User avatar
jsantos
Site Admin
Posts: 2904
Joined: 20 Jan 2012, 17:18
Contact:

Re: upgrading to 1.1.9

01 Jul 2014, 16:28

Something must have failed in the import process of the package. Could you import again and verify that NoesisUnityRenderHook.bundle is being added to your project?
 
g33rt
Topic Author
Posts: 23
Joined: 14 Jan 2014, 16:02

Re: upgrading to 1.1.9

01 Jul 2014, 16:35

I did, and it's not there. It should also be listed in the Unity Import Dialog, right? With the checkboxes? Somewhere in the tree, under Plugins? It's not there
 
User avatar
jsantos
Site Admin
Posts: 2904
Joined: 20 Jan 2012, 17:18
Contact:

Re: upgrading to 1.1.9

01 Jul 2014, 16:41

Yes, look at the screenshot. Does it also happen in a new project?
Screen Shot 2014-07-01 at 16.40.29.png
Screen Shot 2014-07-01 at 16.40.29.png (27.75 KiB) Viewed 3472 times
 
g33rt
Topic Author
Posts: 23
Joined: 14 Jan 2014, 16:02

Re: upgrading to 1.1.9

01 Jul 2014, 16:44

Ok. I manually removed "Noesis.bundle" and the older "UnityRenderHook.bundle". Reimported. Now it's there!

Very strange, in previous imports that I tried it showed as "Noesis.bundle", not as "NoesisUnityRenderHook.bundle", both in the tree and in the finder.
 
g33rt
Topic Author
Posts: 23
Joined: 14 Jan 2014, 16:02

Re: upgrading to 1.1.9

01 Jul 2014, 16:49

Ok. Up and running!

Tnx guys :-)

Who is online

Users browsing this forum: brian9206 and 2 guests