ivan_b
Topic Author
Posts: 87
Joined: 22 Jul 2015, 12:57

iOs performance problem

21 May 2016, 16:38

Hi

When building to an iPad 2 i have a performance problem. The application is very slow.
And also when scrolling a ListBox on an iPad 2 I get "NoesisError: Null item added to collection".
On the iPad Air this only happens if i scroll the ListBox very fast up and down.
What could be the problem?

Thanks
 
User avatar
jsantos
Site Admin
Posts: 2905
Joined: 20 Jan 2012, 17:18
Contact:

Re: iOs performance problem

21 May 2016, 17:01

Could you please create a project reproducing the problem and file a report with it?

Is this something new in 1.2.6 or does it also happen in 1.2.5?
 
ivan_b
Topic Author
Posts: 87
Joined: 22 Jul 2015, 12:57

Re: iOs performance problem

21 May 2016, 17:10

I will test it with the version 1.2.5 and will let you know
 
ivan_b
Topic Author
Posts: 87
Joined: 22 Jul 2015, 12:57

Re: iOs performance problem

21 May 2016, 19:04

This does not happen in the 1.2.5 version and the performance is much better
except for the clipping in the ListBox.
Do you have any quick fix that I could try?
I really need some quick workaround for this.
I will try to reproduce the problem with a simple project.
 
ivan_b
Topic Author
Posts: 87
Joined: 22 Jul 2015, 12:57

Re: iOs performance problem

22 May 2016, 13:04

The problem seems to be with the VirtualizingStackPanel in the ItemsPanel. When I use the StackPanel I don't get the error Null item added to collection.

UPDATE: There is no performance problem, the ScrollUnit in the listbox was set to Item so it seemed to be slow.
For the error "Null item added to collection" seems to occour only when VirtualizingPanel.ScrollUnit="Pixel".
 
User avatar
sfernandez
Site Admin
Posts: 1915
Joined: 22 Dec 2011, 19:20

Re: iOs performance problem

23 May 2016, 19:06

Hi Ivan,

Could you please create a ticket in our bugtracker with a sample to reproduce the "null item" problem?
It seems there is something wrong with the virtualization, but I wasn't able to reproduce it here.

Thanks for your collaboration.
 
ivan_b
Topic Author
Posts: 87
Joined: 22 Jul 2015, 12:57

Re: iOs performance problem

24 May 2016, 09:36

Do I have to submit an xcode project or a Unity project?
After I create a ticket and send you a sample project is there a chance to release a fix soon?
 
User avatar
sfernandez
Site Admin
Posts: 1915
Joined: 22 Dec 2011, 19:20

Re: iOs performance problem

24 May 2016, 12:18

A Unity project would be better, thanks.
Does the application only fail when launching it in iOS? Or it also shows the "null item" message on Unity editor?

As soon as we are able to reproduce and fix the bug, we can release a patch for the 1.2.6 version.
 
ivan_b
Topic Author
Posts: 87
Joined: 22 Jul 2015, 12:57

Re: iOs performance problem

24 May 2016, 14:06

It happens only on iOs.
I can't submit a ticket I get "Your account may be disabled or blocked or the username/password you entered is incorrect."
 
User avatar
sfernandez
Site Admin
Posts: 1915
Joined: 22 Dec 2011, 19:20

Re: iOs performance problem

24 May 2016, 15:02

I don't know if this may be the problem, but you have to create a new user for the bugtracker. Unfortunately forum and bugtracker don't share user credentials.

Who is online

Users browsing this forum: Google [Bot], Roest and 0 guests