View Issue Details

IDProjectCategoryView StatusLast Update
0001132NoesisGUIC# SDKpublic2020-07-07 16:39
Reporterai_enabledAssigned Tosfernandez 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.2f2 
Target VersionFixed in Version3.0.2 
Summary0001132: Selector.SelectedValue and Selector.SelectedValuePath
DescriptionHi guys,

I cannot get working a combobox with custom selected value path.
I found that you wrote in 2014 http://www.noesisengine.com/forums/viewtopic.php?f=3&t=300#p1473 that these properties are not implemented. Is that still so or I'm missing something?

Regards!
TagsNo tags attached.
PlatformAny

Relationships

related to 0001708 resolvedsfernandez ComboBox selection not updating when model changes 

Activities

sfernandez

sfernandez

2017-08-21 14:31

manager   ~0004780

What is the problem you are seeing?
I tried the following sample and it seems to work as expected: https://stackoverflow.com/questions/4902039/difference-between-selecteditem-selectedvalue-and-selectedvaluepath
ai_enabled

ai_enabled

2017-09-01 08:29

updater   ~0004801

Hi Sergio,
the problem is that the SelectedValue binding works only one way to source and not two way (I explicitly set it to be TwoWay).
I.e. it cannot convert SelectedValue back to SelectedItem. It's simply not implemented or doesn't work.
But on selecting item in combobox it indeed updates SelectedValue property, so the problem is only with the way SelectedValue->SelectedItem.

For example, changing the property in my ViewModel (to which Combobox.SelectedValue is bound) doesn't change the selected item in control (and I'm sure I'm calling NotifyPropertyChanged for this property).
Also, right after loading the ComboBox control displays nothing (i.e. no item is selected) when it should take the SelectedValue via databinding and select according item from the ItemsSource.

Please let me know if you need a sample for that.
sfernandez

sfernandez

2017-09-01 12:52

manager   ~0004802

Ok, I understand now the problem.
There is no need for the sample, I was able to reproduce it here, thanks.
ai_enabled

ai_enabled

2017-11-20 12:54

updater   ~0004896

Hi guys,
any updates regarding this issue?
ai_enabled

ai_enabled

2017-11-20 13:15

updater   ~0004897

Ok, don't worry :-). I was able to workaround this by binding to SelectedItem and using a custom converter. 100% hack but works perfectly!
Regards!
sfernandez

sfernandez

2017-11-21 10:41

manager   ~0004902

Sorry, we still didn't have this issue fixed. Hopefully you have a workaround.

Anyway, we will try to solve it for the next release.
ai_enabled

ai_enabled

2018-03-14 09:21

updater   ~0005127

Hi,
I hope we will see the fix planned for the next patch release...
It's a really painful bug as every time we need to use a workaround.
sfernandez

sfernandez

2018-03-14 11:35

manager   ~0005133

Last edited: 2018-03-14 11:35

View 2 revisions

I increased priority to high and will fix it for the next minor release.

ai_enabled

ai_enabled

2020-07-07 14:09

updater   ~0006509

Hi guys,
I wonder if the issue is already fixed or maybe it's trivial to fix now.
Thanks!
sfernandez

sfernandez

2020-07-07 16:39

manager   ~0006511

We fixed this for 3.0.2 version.

Issue History

Date Modified Username Field Change
2017-08-15 15:15 ai_enabled New Issue
2017-08-21 14:31 sfernandez Assigned To => sfernandez
2017-08-21 14:31 sfernandez Status new => feedback
2017-08-21 14:31 sfernandez Note Added: 0004780
2017-09-01 08:29 ai_enabled Note Added: 0004801
2017-09-01 08:29 ai_enabled Status feedback => assigned
2017-09-01 12:52 sfernandez Note Added: 0004802
2017-11-20 12:54 ai_enabled Note Added: 0004896
2017-11-20 13:15 ai_enabled Note Added: 0004897
2017-11-21 10:41 sfernandez Note Added: 0004902
2018-03-14 09:21 ai_enabled Note Added: 0005127
2018-03-14 11:35 sfernandez Priority normal => high
2018-03-14 11:35 sfernandez Note Added: 0005133
2018-03-14 11:35 sfernandez Note Edited: 0005133 View Revisions
2018-11-01 02:14 jsantos View Status public => private
2018-11-22 11:42 sfernandez Target Version => 2.2.0
2018-11-22 11:42 sfernandez View Status private => public
2018-11-22 11:42 sfernandez Platform => Any
2018-11-24 01:35 sfernandez Target Version 2.2.0 =>
2020-07-07 14:09 ai_enabled Note Added: 0006509
2020-07-07 16:38 sfernandez Relationship added related to 0001708
2020-07-07 16:39 sfernandez Status assigned => resolved
2020-07-07 16:39 sfernandez Resolution open => fixed
2020-07-07 16:39 sfernandez Fixed in Version => 3.0.2
2020-07-07 16:39 sfernandez Note Added: 0006511