View Issue Details

IDProjectCategoryView StatusLast Update
0001143NoesisGUIC# SDKpublic2018-12-04 17:39
Reporterai_enabledAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.2f2 
Target Version2.2.0Fixed in Version2.2.0b5 
Summary0001143: Exception "Native type is not registered" when trying to get Parent of ToolTip
DescriptionHi guys,

I'm reworking our in-game tooltip system to use NoesisGUI native tooltip system with minimal customization on our side.
The idea is to use Absolute positioning and manually position control as we need.
The tooltip control template contains my custom content control.
On loaded I can get ToolTip object. But the problem is I can't get parent of this ToolTip object - it throws an exception "Native type is not registered".
Steps To Reproduce
 public class TestTooltipInside : ContentControl
    {
        public TestTooltipInside()
        {
            this.Loaded += this.OnLoaded;
        }

        protected void OnLoaded(object sender, RoutedEventArgs routedEventArgs)
        {
            var tooltip = VisualTreeHelper.GetParent(this) as ToolTip;
            // this throws exception - cannot get the tooltip parent
            var tooltipParent = VisualTreeHelper.GetParent(tooltip);
        }
    }

And style:
 
<Style TargetType="ToolTip">
        <Setter Property="OverridesDefaultStyle" Value="true" />
        <Setter Property="Placement" Value="Absolute" />
        <Setter Property="Template">
            <Setter.Value>
                <ControlTemplate TargetType="ToolTip">
                    <styles:TestTooltipInside>
                        <Border Name="Border"
                            BorderThickness="1"
                            Width="{TemplateBinding Width}"
                            Height="{TemplateBinding Height}"
                            Background="Red"
                            BorderBrush="Blue">
                            <ContentPresenter Margin="4"
                                          HorizontalAlignment="Left"
                                          VerticalAlignment="Top" />
                        </Border>
                    </styles:TestTooltipInside>
                </ControlTemplate>
            </Setter.Value>
        </Setter>
    </Style>

Then create any control and add any tooltip. On hover tooltip should be opened and TestTooltipInside will be instantiated, when it's loaded an exception is thrown.
TagsNo tags attached.
PlatformAny

Activities

sfernandez

sfernandez

2017-08-30 12:25

manager   ~0004797

Thanks for reporting, I found what is happening and will solve it for the next release.
ai_enabled

ai_enabled

2018-03-15 09:51

updater   ~0005134

The issue is still happening in v2.1.0f1.
ai_enabled

ai_enabled

2018-03-15 10:20

updater   ~0005137

I think it's not critical for us as I can use tooltip HorizontalOffset and VerticalOffset properties...
But we definitely need https://www.noesisengine.com/bugs/view.php?id=1142 fixed to make proper tooltips and get rid of our custom tooltips system (it's quite inconvenient to use as we can't simply set ToolTip property in XAML or C# and have to use our custom attached property like this:
ui:ToolTipServiceExtend.ToolTip="{Binding TooltipContent}">

Issue History

Date Modified Username Field Change
2017-08-28 15:45 ai_enabled New Issue
2017-08-28 15:45 ai_enabled Product Version => 2.0.2f2
2017-08-28 15:45 ai_enabled Steps to Reproduce Updated View Revisions
2017-08-28 15:46 ai_enabled Steps to Reproduce Updated View Revisions
2017-08-28 15:46 ai_enabled Steps to Reproduce Updated View Revisions
2017-08-30 12:24 sfernandez Assigned To => sfernandez
2017-08-30 12:24 sfernandez Status new => assigned
2017-08-30 12:25 sfernandez Note Added: 0004797
2018-03-15 09:51 ai_enabled Note Added: 0005134
2018-03-15 10:20 ai_enabled Note Added: 0005137
2018-11-01 02:14 jsantos View Status public => private
2018-11-22 11:47 sfernandez Target Version => 2.2.0
2018-11-22 11:47 sfernandez View Status private => public
2018-11-22 11:47 sfernandez Platform => Any
2018-12-04 17:39 sfernandez Status assigned => resolved
2018-12-04 17:39 sfernandez Resolution open => fixed
2018-12-04 17:39 sfernandez Fixed in Version => 2.2.0b5