View Issue Details

IDProjectCategoryView StatusLast Update
0001148NoesisGUIUnity3Dpublic2018-12-27 11:18
ReportereasylaserAssigned Tosfernandez 
PrioritynormalSeverityblockReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version2.0.2f2 
Target Version2.2.0Fixed in Version2.2.0b5 
Summary0001148: NoesisException: Calling thread (12260) doesn't have access to this object (10004)
DescriptionHi,
We are getting this exception rather often.
After running a debug build of noesis I tracked it down to "NoesisGUI_PINVOKE.delete_StreamGeometryContext(swigCPtr);".

In the C++ the call chain are: ~StreamGeometryContext -> Close -> UpdateFillRule -> SetFillRule ....

So, what to do? remove the close from the destructor?
TagsNo tags attached.
PlatformAny

Activities

andreasg

andreasg

2017-09-15 14:45

reporter   ~0004814

As a quick solution, I added Dispose calls in our code to force the destructor to run in main thread
sfernandez

sfernandez

2017-09-20 16:48

manager   ~0004817

I was going to suggest to follow the using pattern:

StreamGeometry geom = new StreamGeometry();
using (StreamGeometryContext ctx = geom.Open())
{
    ctx.BeginFigure(...);
    ctx.LineTo(...);
    ctx.LineTo(...);
}
return geom;


It should automatically call Dispose.
andreasg

andreasg

2017-09-21 08:04

reporter   ~0004820

I know, that is my quick fix.

But the problem is still there, the Finalizers in .net is executed in some GC thread. That must be handled correctly.

Issue History

Date Modified Username Field Change
2017-09-15 13:51 andreasg New Issue
2017-09-15 14:45 andreasg Note Added: 0004814
2017-09-20 16:48 sfernandez Assigned To => sfernandez
2017-09-20 16:48 sfernandez Status new => feedback
2017-09-20 16:48 sfernandez Note Added: 0004817
2017-09-21 08:04 andreasg Note Added: 0004820
2017-09-21 08:04 andreasg Status feedback => assigned
2017-12-14 09:37 sfernandez Reporter andreasg => easylaser
2018-11-01 02:14 jsantos View Status public => private
2018-11-22 20:49 sfernandez Target Version => 2.2.0
2018-11-22 20:49 sfernandez View Status private => public
2018-11-22 20:49 sfernandez Platform => Any
2018-12-27 11:18 sfernandez Status assigned => resolved
2018-12-27 11:18 sfernandez Resolution open => fixed
2018-12-27 11:18 sfernandez Fixed in Version => 2.2.0b5