View Issue Details

IDProjectCategoryView StatusLast Update
0001213NoesisGUIUnity3Dpublic2019-02-12 03:49
ReporterphilongAssigned Tosfernandez 
PriorityhighSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.1.0b4 
Target Version2.2.0Fixed in Version2.2.0b6 
Summary0001213: Korean TextBox Typing wrong
DescriptionSometimes, it has a missing character when I typing the Korean language

Control : TextBox

I do the test and debug, and i found the event send right character [Method : ProcessEvent, class NosesisView]
 _uiView.Char((uint)ev.character);

But TextBox don't display character.
Steps To ReproduceUsing TextBox Control
Change keyboard to Korean Microsoft IME
Enable Korean Typing

-> Backspace few time.
-> Type gksrmf +space
-> Expect 한글
--> Result 글
TagsNo tags attached.
PlatformAny

Relationships

related to 0001243 resolvedjsantos Korean IME input in Unity 2017 

Activities

jsantos

jsantos

2017-12-28 12:00

manager   ~0004963

Are you sure the glyph is contained in the True Type you are using?

Could you attach here a XAML with just a TextBlock reproducing the error?
philong

philong

2018-01-02 03:31

reporter  

TextBox.xaml (5,905 bytes)
philong

philong

2018-01-02 03:31

reporter   ~0004964

Hi jsantos,
I using font Arial Unicode MS, could you try with textbox NoWrapText

I found another bug, it does not support single character Korean (some times) . Let type "g" + space.
jsantos

jsantos

2018-01-03 01:56

manager   ~0004966

Could you create a single XAML with just one TextBlock (not TextBox) and with the characters that are giving trouble to you? That way it is easier to debug for us. if possible, please also include the font (just in a single .zip and upload it to google drive or something similar because we don't allow big attachments here)

Thanks!
philong

philong

2018-01-03 02:17

reporter   ~0004967

Hi jsantos,
It not related to display Korean, the bug is when we typing the Korean not correctly
For debug, could you install Korean keyboard IME

-> Backspace few time.
-> Type gksrmf +space
-> Expect 한글
--> Result 글

Font :
https://drive.google.com/open?id=1hxje5CUxjN0iJTJKqCLDp6jgJdIqZiQT

Thank you

TextBox-2.xaml (1,126 bytes)
jsantos

jsantos

2018-01-03 02:25

manager   ~0004968

Thanks for your feedback, so there is no problem when you display those characters in a textblock, the issue is only happening in the textblock, right?
It seems to be a IME issue then (as you perfectly pointed out)
philong

philong

2018-01-03 02:33

reporter   ~0004969

The problem is Typing Korean in TextBox
Thank you.

Issue History

Date Modified Username Field Change
2017-12-27 11:01 philong New Issue
2017-12-28 11:59 jsantos Assigned To => jsantos
2017-12-28 11:59 jsantos Status new => assigned
2017-12-28 12:00 jsantos Status assigned => feedback
2017-12-28 12:00 jsantos Note Added: 0004963
2018-01-02 03:31 philong File Added: TextBox.xaml
2018-01-02 03:31 philong Note Added: 0004964
2018-01-02 03:31 philong Status feedback => assigned
2018-01-02 04:54 philong Category C# SDK => Unity3D
2018-01-03 01:56 jsantos Status assigned => feedback
2018-01-03 01:56 jsantos Note Added: 0004966
2018-01-03 02:17 philong File Added: TextBox-2.xaml
2018-01-03 02:17 philong Note Added: 0004967
2018-01-03 02:17 philong Status feedback => assigned
2018-01-03 02:25 jsantos Note Added: 0004968
2018-01-03 02:25 jsantos Status assigned => feedback
2018-01-03 02:25 jsantos Assigned To jsantos => sfernandez
2018-01-03 02:33 philong Note Added: 0004969
2018-01-03 02:33 philong Status feedback => assigned
2018-11-01 02:14 jsantos View Status public => private
2018-11-22 11:53 sfernandez Target Version => 2.2.0
2018-11-22 11:53 sfernandez Platform => Any
2018-11-22 11:53 sfernandez View Status private => public
2019-02-12 03:48 jsantos Relationship added related to 0001243
2019-02-12 03:49 jsantos Status assigned => resolved
2019-02-12 03:49 jsantos Resolution open => fixed
2019-02-12 03:49 jsantos Fixed in Version => 2.2.0b6