View Issue Details

IDProjectCategoryView StatusLast Update
0001326NoesisGUIC# SDKpublic2019-02-26 18:41
ReporterJasonL663Assigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version2.2.0Fixed in Version2.2.0b7 
Summary0001326: Managed Library Classes Defined in Global Namespace
DescriptionThe NoesisAppManaged.Windows library defines 2 classes in the global namespace:

- Application
- Window

Since these are common names, this can cause issues for developers wishing to
use these names for other purposes.
Steps To ReproduceTry to introduce and use the System.Windows.Window or System.Windows.Application
classes into the global namespace with a using statement:

Example:
using System.Windows;
class MyWindow : Window
{

}

Example:
using Application = System.Windows.Application;
class MyApp: Application
{

}

Observe how these examples fail to compile due to naming conflicts. Since these
class names are defined in the global namespace, the only way to resolve this
issue is through the awkward namespace alias feature in C#
TagsNo tags attached.
PlatformAny

Activities

admin

admin

2018-10-30 12:44

administrator   ~0005266

Our hosting company corrupted our database without a backup. We are manually reconstructing all the issues.
sfernandez

sfernandez

2019-02-26 18:41

manager   ~0005480

Application and Window moved inside NoesisApp namespace to avoid collision with global namespace definitions.

Issue History

Date Modified Username Field Change
2018-10-30 12:43 admin New Issue
2018-10-30 12:43 admin Reporter admin => JasonL663
2018-10-30 12:44 admin Note Added: 0005266
2018-11-01 02:14 jsantos View Status public => private
2018-11-22 09:56 sfernandez Assigned To => jsantos
2018-11-22 09:56 sfernandez Status new => assigned
2018-11-22 09:56 sfernandez Target Version => 2.2.0
2018-11-22 09:56 sfernandez View Status private => public
2018-11-22 09:56 sfernandez Platform => Any
2019-02-13 21:25 jsantos Assigned To jsantos => sfernandez
2019-02-26 18:41 sfernandez Status assigned => resolved
2019-02-26 18:41 sfernandez Resolution open => fixed
2019-02-26 18:41 sfernandez Fixed in Version => 2.2.0b7
2019-02-26 18:41 sfernandez Note Added: 0005480