View Issue Details

IDProjectCategoryView StatusLast Update
0001329NoesisGUIC# SDKpublic2018-11-30 14:43
ReporterC4usticAssigned Tosfernandez 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version2.2.0Fixed in Version2.2.0b5 
Summary0001329: Exceptions in converters is thrown at confusing times.
DescriptionExceptions thrown in converters are "buffered" in the Noesis.Error class and not
thrown until something else runs Check. This causes very confusing exceptions to
be thrown at the wrong time.
TagsNo tags attached.
PlatformAny

Activities

admin

admin

2018-10-30 12:49

administrator   ~0005269

Our hosting company corrupted our database without a backup. We are manually reconstructing all the issues.
admin

admin

2018-10-30 12:51

administrator   ~0005270

----------------------------------------------------------------------
 (0005269) C4ustic (reporter) - 2018-09-30 11:48
 https://www.noesisengine.com/bugs/view.php?id=1329#c5269
----------------------------------------------------------------------
Yes sure, I think it is a fairly usual case.
I set the binding in code:
c_slider = GetTemplateChild("PART_slider") as Slider;
c_sliderBinding = new Binding("SliderValue");
c_sliderBinding.Source = c_propertyItem;
c_sliderBinding.Path = new PropertyPath("Value");
c_sliderBinding.Mode = BindingMode.TwoWay;
c_sliderBinding.Converter = new NsUIConverters.NsFloatToInt();
BindingOperations.SetBinding(c_slider, Slider.ValueProperty, c_sliderBinding);

The exception should have been thrown during the SetBinding() call because it
runs the converter which throws an exception. However what happened is that the
next Noesis Code that happens to run throws that exception instead.

I have another Converter issue where I get a call to Convert when I expected
ConvertBack to be called. I don't know enough about WPF to know if this is a bug
though. I expected ConvertBack to be called every time the target changes and
Convert every time the source changes. It that is supposed to be the case you
have another bug there.

Another thing that isn't really a bug but it is very annoying is that the code
that builds Noesis Assets must have write rights to the source files. This makes
it so I must check out every UI source file and run reimport every time I open
Unity. This goes for font files too. It is not necessary since you never change
anything in the source file. To be clear in order to properly build
MyMenu.asset, MyMenu.xaml must not be write protected.
----------------------------------------------------------------------

Issue History

Date Modified Username Field Change
2018-10-30 12:48 admin New Issue
2018-10-30 12:48 admin Reporter admin => C4ustic
2018-10-30 12:49 admin Note Added: 0005269
2018-10-30 12:51 admin Note Added: 0005270
2018-11-01 02:14 jsantos View Status public => private
2018-11-22 09:59 sfernandez Assigned To => sfernandez
2018-11-22 09:59 sfernandez Status new => assigned
2018-11-22 09:59 sfernandez Target Version => 2.2.0
2018-11-22 09:59 sfernandez View Status private => public
2018-11-22 09:59 sfernandez Description Updated View Revisions
2018-11-22 09:59 sfernandez Platform => Any
2018-11-30 14:43 sfernandez Status assigned => resolved
2018-11-30 14:43 sfernandez Resolution open => fixed
2018-11-30 14:43 sfernandez Fixed in Version => 2.2.0b5