View Issue Details

IDProjectCategoryView StatusLast Update
0001338NoesisGUIC++ SDKpublic2022-11-16 16:38
Reporterrealesmedia Assigned Tosfernandez  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.1.0f1 
Target Version3.1.6Fixed in Version3.1.6 
Summary0001338: cyclic reference when using child user control with DataContext binding on the Parent Control
Descriptionsimplified XAML for Window:

<Window x:Class="TrackEditor"
        xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
        xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
        xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
        mc:Ignorable="d"
        Background="#303033" Height="300" Width="900"
        Title="Track editor" x:Name="window" IsEnableWindowButtons="True">

  <Grid>
   
<!--UserControl.-->
    <WindowCaption Height="30" VerticalAlignment="Top" Background="#01000000" Margin="1,1,30,1" DataContext="{Binding ElementName=window}">
    </WindowCaption>

  </Grid>
</Window>


if you use DataContext = "{Binding ElementName = window}"> then when you destroy a window, mView.Reset () does not call WindowCaption () destructor and you cannot destroy Window () because of NumRefCounts > 1

Window is holding a WindowCaption,
WindowCaption holds a window
TagsNo tags attached.
PlatformAny

Relationships

related to 0001287 resolvedsfernandez Circular dependency produces memory leaks 
related to 0001153 resolvedsfernandez Memory leak when using ContextMenuService.PlacementTarget 

Activities

sfernandez

sfernandez

2022-11-16 16:38

manager   ~0008160

Solved in changeset r11723

Issue History

Date Modified Username Field Change
2018-10-30 13:22 realesmedia New Issue
2018-11-01 02:14 jsantos View Status public => private
2018-11-22 10:00 sfernandez Assigned To => sfernandez
2018-11-22 10:00 sfernandez Status new => assigned
2018-11-22 10:00 sfernandez View Status private => public
2018-11-22 10:00 sfernandez Platform => Any
2018-11-22 10:00 sfernandez Relationship added related to 0001287
2018-11-22 10:01 sfernandez Relationship added related to 0001153
2021-06-03 11:37 sfernandez Target Version => 3.1
2022-11-16 16:38 sfernandez Status assigned => resolved
2022-11-16 16:38 sfernandez Resolution open => fixed
2022-11-16 16:38 sfernandez Fixed in Version => 3.1.6
2022-11-16 16:38 sfernandez Target Version 3.1 => 3.1.6
2022-11-16 16:38 sfernandez Note Added: 0008160